No sound with USB playing with MPD


#1

There is no sound with the MPD settings over USB

audio_output {
type "alsa"
name "Audio USB"
device "hw:2,0"
replay_gain_handler "none"
mixer_type "hardware"
dsd_usb "yes"
dop "yes"
format "*:24:2"
buffer_time "200000"
period_time "1024000000"
use_mmap "yes"
auto_resample "no"
auto_channels "no"
auto_format “no”
}

I have sound over SP/Dif Toslink and also with a Sabre Matrix DAC I have sound over the USB interface.


#2

[Assuming you have a DS, not a DS Jr.] Does the DAC have a green dot in the USB input selection icon/button? If so what format are you playing and what format does the DAC display (e.g. 16/44.1k). If not, have you powered down the DAC AND the PC and then powered them up again?


#3

I am playing with a PS Audio Nuwave DSD DAC.

These are the alsa: the 1st audio output card is SP/DiF Toslink with sound and the 2nd output is USB with NO sound.

What is going on?

[root@server1 Downloads]# cat /proc/asound/card*/pcmp/sub/hw_params
closed
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 4800
buffer_size: 9600
closed
closed
closed
closed
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 4800
buffer_size: 9600
[root@server1 Downloads]#


#4

What is you Kernel Version. If it is less that 4.2 there might be issues with the USB drivers.

Dennis


#5
demo01 said There is no sound with the MPD settings over USB

audio_output {
type "alsa"
name "Audio USB"
device "hw:2,0"
replay_gain_handler "none"
mixer_type "hardware"
dsd_usb "yes"
dop "yes"
format "*:24:2"
buffer_time "200000"
period_time "1024000000"
use_mmap "yes"
auto_resample "no"
auto_channels "no"
auto_format “no”
}

I have sound over SP/Dif Toslink and also with a Sabre Matrix DAC I have sound over the USB interface.


With AP Linux, I think you should be showing a Card under “name” and not just “Audio USB”. Reboot with the DAC connected and turn on. Under DAC setup, click on List Cards, and I think it should show a card with PS audio listed.

Mine shows the following: Card 0: P20 [PS Audio USB Audio 2.0], device 0: USB Audio [USB Audio]

I’m no expert, but I hope that helps.