PIKES PEAK issue


#1

I spent a lot of time and thought troubleshooting this. It’s easy to get confused, but it isn’t the amp, cables, pwt, or speakers - AND as I wrote in the header, I just reloaded v121 and it’s stereo!!! BTW: used same 2GB card for both.


#2

Check your balance control settings - sometimes after an upgrade the balance is off.


#3

Well, after reloading v123 it works. Stereo. Thanks and to all sorry I bothered you.


#4

And going in to listen, no, it isn’t in stereo. I had turned up the volume and it sort of filled the room and I thought it was both channels, but it’s not. One only. Since v121 works as it should, ???


#5

Balance control? I feel incredibly stupid to ask, Ted, but IS there a balance control on either the pwt or dsddac? That’s it - straight to amp. No balance control I know of.


#6

The remote for the DS has buttons marked “L” and “R” at the bottom left. I believe Left and Right got accidentally reversed in Pike’s Peak so try both buttons if nothing happens.


#7

Don’t think I’ve been clear. on my dsddac, v121 works fine, v123 only plays in one channel.


#8

I think we understand you, but we don’t yet unambiguously know if using the balance controls change anything for you or not. The balance is written in an EEPROM but options are written to different locations in different releases. The PP balance being set wrong is the most likely thing that matches your symptoms. The second most likely is one of the mute relays not working with PP, but that doesn’t make much sense since no one else has seen it (in any release.)


#9

I believe everyone understands.

They want to make sure however that you check the balance control after switching to 123. On occasion the balance is skewed after switching firmware. It can be so off of center as to make it appear that a channel is missing.

Please check the balance setting on the DAC after loading 123 and be sure the balanced control is centered (the numbers for left and right are the same). If the balance setting is correct, something else is going on and we will try to help.


#10

After the helpful post above, I checked: v121 - it was balanced.

Last night right before bed, I tried loading v123 again and it didn’t work at first, then the screen seemed to stutter and it stabilized and appeared v 123 loaded (btw: I checked balance now that I realize the two remotes (pwt and dsd) are NOT exactly the same and I was using the one without balance.) Well, it loaded v 123. Checking balance it was 50/50. I turned on the amp and it worked, I believe at first I heard no audio on the left then it popped on.

Then to bed, later today to find out what is on there.

Seemed to me that just accessing the level control, even though it said 50/50, somehow enabled the update.

When I wrote no audio I mean completely dead. Ear to speaker dead.

Just checked. It’s working. Audio on both channels, v123 loaded. A mystery.


#11

Now it’s dead again. Turning the rear switch off then on gets me a burst through the left channel before it dies. I’d say a half second of music.


#12
woodburger100@gmail.com said Now it's dead again. Turning the rear switch off then on gets me a burst through the left channel before it dies. I'd say a half second of music.
You probably should call or email PS Audio support - if a burst of audio happens just after you turn off the power switch either your mute relays aren't working well or the control processor has crashed. Neither one of these is normal. But support has more practical experience debugging these things than I do.

#13

Thanks for this thread. When I got back from a long weekend away and turned on the Directstream - left channel dead. (It worked fine before). Never realized there is a balance option on the remote.

For some reason the left channel balance got reset to zero. Fixed, happy listening again!