PM not visible


#1

I received an email saying that I have a new PM. The icon at the top of the PS forum page shows “Inbox: 1”. But I cannot see the new message. (My old PMs are still there, as they have been.) I tried earlier today from my iPad and just tried again now from my computer at home, same result both times. Any suggestions?


#2

May be a red herring. I’ve had that for months now as well as a few others. I also got a notification but couldn’t locate the rogue PM. Hopefully it’s just a message from the Nigerian First Official Ministry of Financial Investigatorial Refundation…


#3

It may be worth closing your browser, clearing the cache, and staring anew.


#4

Thanks, guys. It’s probably not spam, since the topic of the PM, as shown in the email I received, is related to a forum topic I have posted in recently. Restarting the browser (firefox), and then trying a totally different browser (internet explorer), did not change anything.

BTW (probably not the source of my problem): the PSA website is like molasses today. Really, annoyingly slow. On both the browsers I tried just now as well as earlier today. I have fast FIOS and normally do not have to wait for websites.


#5

+1 on slow website today.


#6

Sometimes people change their mind and delete a PM (or post) before you get to read them. The site software often still show a pending PM (or post) message…