Power Plant Premier does not respond to remote control commands

My PPP suddenly stopped responding to the remote control commands. Strangely the “Display” dimming command from this remote control is still responding. What to do?

Have you tried powering down, unplugging the unit, and letting it sit for a bit before turning it back on?

I would also refresh the remote’s batteries even though the unit is responding to the display command.

After you try what Elk recommends, if it doesn’t work, we do still have a remote that works with the PPP. The are $15 and we would need to charge shipping if you’re outside the U.S. Keep me posted if you need one and we can get it sent out.

Hello Elk,

Thank you for the advise.

I had already checked the batteries (1,53 V) and powered down the complete unit for 30 seconds (mains connector).

Now on your advise did I renew the batteries and did power down the PPP for 2 minutes. Problem remains: not reacting to any remote control command, strangely the Display dimming function via the remote control still works.

regards, Gertjan

Hello Jamesh, I am considering that final option. But it is strange that the Display dimming keeps functioning normally. I would think it can’t be the Remote control itself or am I mistaken.

Do you happen to have a remote from another piece of PS Audio equipment you can try?

Do the buttons on the front of the unit operate normally? If so, I suspect the remote is the source of the problem.

Yes, the remote could be on its way out. When this happens, a few functions can still work but a majority won’t.

Hello Jamesh, I will go for that option remote you can sell me. Please let me know how to set this motion. Delivery to the Netherlands.

Go ahead and shoot me an email with your shipping address and phone number and I’ll be able to get the ball rolling. jamesh@psaudio.com

Hello James, thank you for the great acvice and solution, the new remote solved the problem.
Regards, Gertjan

1 Like

Awesome, glad the new remote did the trick!