Problems with Roon and My Nucleus+

I’m having a ton of problems with Roon and My Nucleus+. Getting help from Roon support is tough when you have to wait 3-5 days for a response for the next step.

The App with Silent Angel (VitOs) works great with my NAS.
unfortunately Roons interface etc is far superior.
Without a decent interface it’s a challenge to deal with 140,000 tracks

Have you tried the roon forums? lots of smart people who have probably hit the same issue there. Plus their support trolls the forums and publishes help. Much better than email.

No solutions yet

Can i ask what’s wrong? You can PM or post here

Thank you for asking. I’ll try to keep it brief since this isn’t the appropriate thread
I have a library of 144,000 FLAC files stored on my NAS.
commonly…though not all the time…when a song is selected it can take up to 2 minutes for music to begin playing.
I also have tried connecting an external HD to my Nucleus+ but ended up getting alot of “track loading errors”
At the advice of Roon support I tried a much smaller Library (5000 tracks) and things worked great…as soon as my track number crept over 30,000 tracks the problems started again.
It also extends to navigation within the controllers with Artists, tracks, etc taking minutes to load and be displayed.
I understand it maybe apples to oranges comparison but the App that comes with my streamer works great. I’d switch to it full time but it falls short of Roon in it’s interface and catalog functions.
At this time Roon Support can’t tell me what’s going on. They think it might be my library but nothing is identified in the “skipped track section”
It’s maddening because I know lots of users have more tracks then me and have no issues
Thanks again and apologies, if necessary, for taking this thread of it’s track

Very strange. Normally I would say what drive is on your core and what drive are you using on the NAS. If either is having issues that could slow this down. Not an expert on how to do it, but would do a drive check on both. not sure how to even do that with a nucleus.

I assume the test of 5000 was same NAS right? Something is causing the search/find/play to operate slow. If 5000 worked its not the network. I was thinking the index which is the meta data on the core DB. Or if the NAS could not index it. But that would show in the 5000 I would think. The + is supposed to be able to handle that size. if I had to guess issue with the hard drive in the + or they did not give you enough memory. The NAS is just the end point. the UNC location of the file should be super fast. Can you access the NAS and it seems zippy when you are doing things on it?

Indeed, perhaps we should be forked onto another thread. I guess we can ask admin…

I had the same first question about the NAS. Are the regular upload / download speeds like before when using other devices to access the NAS?

Another question: When did the problem start? Was it after any particular device had a major operating system update? Did you recently get a lot of files?

How much RAM do you have on the Nucleus-Plus? 32GB at least would be advisable for your library size.

Do you leave it on all the time? Or do you reboot a lot, resulting in new library scans?

Yeah NAS functions just fine.
I added memory to my Nucleus+ (now at 32 GB) but it hasn’t helped this issue

Think this has been going on for sometime and I sorta lost appreciation in how Room is supposed to work.
It’s a nightmare
I very much appreciate all of your help but I’m very sensitive to screwing up this Red Thread
Also happy to discuss this all that will be tolerated

I leave on all the time
Have just gradually accumulated more files over time
No big bolus

I would go back to the SSD inside the Nucleus then. that is where the Meta data is stored to access the NAS. wonder if its full when the DB hits that big. I have no idea how to check those stats along with performance stats of that SSD.

I’m in Roon supports hands now.
It’s certainly not the best support model out there but it’s all I got at this point

Thank you Elk
Wasn’t intending on using this forum for my Room Woes but here we are
I can use all the help I can get

1 Like

It is perfectly find to ask for help with any audio issue in this forum. :+1:

But please start a different thread if it is off-topic in existing threads. :slight_smile:

I hope you get things sorted out.


From personal experience I recommend the Samsung 870 QVO with 8TB. Ask the Roon folks if the Nuc-Plus will take that.

I had a 4tb Samsung EVO in my Roon Nucleus when I owned it I don’t why a 8tb wouldn’t work for you.

Just the Roon website mentioned the top-end for onboard SSD as 4TB. But that may simply pre-date the existence of 8TB SSDs…

1 Like

Thank you -ive sent all these suggestions to Roon support

Using totally different hardware I had the same issue whereby selecting certain tracks would result in a very long wait (sometimes two minutes, sometimes maybe only 20 seconds). I use a Melco server connected by USB to a Chord MScaler. I’m pretty sure the problem occurred when changing from, say, a 44.1/16 to a 96/24. I suffered with this for a few days and then it suddenly went away. I may have done a backup of the Melco (acting like a NAS) before noticing that the problem cleared. I suspect a rogue process running on the Melco (I have it configured as Raid 1 and maybe the file indexing was screwed in some way but fixed itself eventually).

Whenever this happens, I restart Nucleus+ (from its web interface in the tablet) and thing go back to full speed.
Do you like Melco as a Roon endpoint?