Help, I am all (Network) thumbs

Hoping someone more knowledgeable than me that has been down this path can help me sort something out.

I nearly ran out of storage on my iMac for ripping discs so I successfully re-oriented dBpoweramp Music Converter such that it now rips to my Synology NAS.

So, new rips are now on the NAS and the JRMedia Center software I run “sees” the new files just fine (I had no trouble adding the new file location to the list of “directories” JRMC pings to organize and render my music library.)

With Roon however, I had no such luck adding the files’ location to the list of storage locations Roon should ping to do its thing.

The online Roon help page was a bust. Two or three canned pages looked to provide the answers but I spent way too much time late last night attempting to follow the directions - to no avail.

Anyone here have experience adding a new folder to the existing “database” when the new folder is on the NAS and Roon Core is on an iMac and the NAS is hardwired to the iMac via Ethernet?

Thanks in advance.


[Edit: See Post #7 for a better definition of the problem. Thanks.]

Your path will probably look like:

\name of device\directory

So maybe something like this:


Edit: grrrrr! The forum app won’t let me type what I want!

I had to put the path in a note and take a screenshot. The Discord server won’t let me put a path in a posting.

For syntax characters, which backslash appears to be, the normal practice is to double up if you want a single printable character such as in \\root\branch, which I typed with an initial four backslashes and then two together


Macs don’t use backslashes for paths. Ever. And I’m very sure you won’t get that to work by substituting forward slashes. But my apologies I don’t know the actual answer to the original question.

Really needs to be a question on the Roon Community forum rather than here.

1 Like

Oh, apple… Foreign language. Thanks for pointing that out.

1 Like

I have been to the Roon site and failed to find a direct response. I have not yet posted an inquiry on a chat board there yet. That said, I am still optimistic that someone here with relevant experience will chime in. If unsuccessful, I’ll wade back in over on the Roon forum.


Thanks “V”.

Following are a couple more pieces of the puzzle I am trying to solve.

First, a picture of what the iMac shows as the path/network location I am trying to direct Roon to:

Second, if I understand the process, according to Roon I am simply supposed to enter the Network Share Location as prompted:

When I copy the network location and hit enter for the Network Share Location I get an error message:

The Roon Q&A on this topic indicates that a different prefix other than afp:// has to be used. However, when I tried the other, recommended prefix (the specifics escapes me at the moment) I get the same error message.

Thanks in advance to all willing to chime in here. I have to believe I am not the first Forum Denizen to attempt this.


OK, those screenshots help HEAPS.

Try putting smb://Ellis_Network.local/music/dBpoweramp%20Rips into Roon and see what happens.

If that fails, try replacing %20 with a single space character in Roon.


On it!

Will circle back soonest…

Tried original suggestion and: “smb://Ellis_Network.local/music/dBpoweramp&Rips”.

No luck. Bummer.

Thanks for trying. Please let me know if you get additional inspiration.

Since Roon offers the alternative, try this:
\\Ellis Network\music\dBpoweramp Rips

You might need to add username and password in either form

Why the ampersand? Did you try with the space?

No. Was going with the “single space character” but misunderstood what you meant, I think…


Tried this: \Ellis Network\music\dBpoweramp Rips and

smb://Ellis_Network.local/music/dBpoweramp Rips.

No luck.

If you know the IP address of your NAS, try putting that in place of “Ellis Network” or its underscore variant

1 Like

Now you have totally eclipsed my limited level of knowledge.

Appreciate your time and consideration - care to share how I might go about identifying the IP address for my NAS?

Has to be a way to extract that from my setting somewhere or look it up…right?

Thanks again,


Another relevant puzzle piece(?):

When I right click on the “Where” information (see Server afp network mapping information/image I posted previously) and then click paste, the path for music is represented as:


Does this inspire any further suggestions? (I have tried simply plugging this in already as well.)

Thanks again.

Check the following document:

Your format should be something like:
smb://MyNASDrive/Multimedia/Music or smb://

Thank you. I will take a look soonest!