PWT CD drive issue

Hi, I need some help here. I recently had my CD drive replaced. I was originally deal with Jeremy Bretey and then Mark Simpson.

My issue is after the drive has been replaced all my Hybrid SACD not longer able to read. But Regular without any issues. I have all the latest firmware updated still not able to resolve the issue.

Yesterday, all of the sudden, it was able read one Hybrid SACD and able to play. After eject and retry again it never able to read again.

To me this seems like the replacement drive is defective as suddenly able to read one time.

I emailed back to both Jeremy and Mark for over 1.5 week now and I have receive not response.

If someone from your team can help me out that would be greatly appreciated.



Welcome, Jason!

Hi Jason.
Do regular CDs play?
Have you tried cleaning the lens?
If not, there are cleaning discs, such as this one, that might work. Alternatively, you can open the PWT, open the transport cover, and directly clean the lens with a clean, dry Q-tip or micro fiber cloth. It’s possible that there is some bit of debris that is causing a problem. Good luck.

The CD drive is brand new that I ordered directly feom PS audio back in Dec 2018, the drive got shipped to me in January 2019.

So there is no reason why I should clean the lens on a brand new drive ??

It does read and play regular CD no issue at all.

The reason why I replace the drive because the CD tray will retract even a light touch and start skipping. But the original drive able read any hybrid CD with any issue.

You can’t read hybrid SACDs and this may be due to debris on the lens which could have become contaminated during manufacture, assembly, transport, or while in your home. It’s just a suggestion in response to your request for help. If you feel that there is absolutely no way a mechanism that is open to the air could become dirty, then don’t clean it.

Hi Peanut Butter,

I just insert my cd lens cleaner CD to clean the lens. I also use compress Air to give a blow too.

I try to put in my hybrid CD after the cleaning still not able to read.

One strange behavior that I forgot to mention is if I insert any Hybrid SACD as soon as I power one the PWT, then I will read the disc. But once you eject the disc and put it back then it wont’ read any more. Continue reading any normal CD is perfectly fine without issue.



Well, that does sound more like a hardware problem. Is the new drive the same model as the old one?

I do not believe so, but I can’t remember the exact model between Original drive and replacement drive.

that’s why I respond back to the PS Audio staff that I dealt with for my replacement drive. But for some reason, I am not getting any response back from them.

That is why I decided to post my issue here seeking for help and hopefully Paul McGowan will see my post and help me out.



You can email Paul directly:

1 Like

Thank you.

I just emailed Paul

Hopefully will hear back from him



1 Like

Hi Jason,

I checked in with Paul and Mark and we’ll get you back up and running in no time. Mark will get back to you by the end of today.

Looking forward to getting everything back up and running for you!