Streaming DSD (DFF) tracks from Synology DS212J


#1

Apologies if this isn’t the most appropriate forum to raise this query but it relates to playing DSD files to my Directstream, so it seemed right…

I’ve just uploaded some of my SACDs to my Synology DS212J, which is a few years old with 256M of RAM and a 1.2ghz processor.

I’m streaming the files to an Auralic Aries, controlled via the Lightening DS, and onwards via USB to my DS.

Whilst I can play all of the tracks and the sound quality is superb, I’m having problems selecting tracks from Lightening DS. I either have to select the track multiple times before it plays or I have to find a different track that works and then go back to the one I wanted, either directly or by skipping to it.

Once a track is playing there’s no problem and I can skip up and down an album with no issue - it 's just when I try and jump directly to a track. And it doesn’t happen every time - sometimes it’s fine.

This problem has only started since I uploaded my SACDs - it wasn’t a problem on standard or hi Rez PCM files. And I’ve rebooted and deleted and reinstalled my library a few times.

I’ve dropped an email to Auralic but I’m wondering if the problem is with my NAS? Do I need a NAS with more processing power to properly play DSD/DFF files? Does anyone on the forum have any experience playing DSD files from older Synology NAS drives?

Many thanks,

Mike.


#2

Sorry, just realised I should have raised this in the DSD forum - is any of the forum guru’s able to move it for me? Mike.

[It is perfect here or the DSD forum. :slight_smile: Elk]


#3

Hi Mike,

not sure if that’s the reason but would recommend the DSF format for saving the DSD files. DSF is also better for tagging. I had the Auralic Aries a couple of months and no problems with playback of DSF files at all.

Mario


#4

Hi Mario, thanks for suggestion. When I unpack the .iso file, it automatically shows them as DFF. Do you know if there is any way of converting DFF files to DSF after the fact, without impacting the integrity of the file? Thanks, Mike.


#5

When I open the batch file it looks like this:

dsd2dsf-1.jpg

I think you need to add the “-s” to extract the DSD files from the .iso to .dsf automatically. Or have a look at Sonore APPS - ISO2DSD

To convert DFF files to DSF I have an older version of Korg AudioGate but I just found this: DFF to DSF v1.1.0


#6

Thanks again Christian, I’ll have a play with that later this evening.

In the meantime Auralic have come back and suggested I need to check the box marked “DSD over PCM (DoP V1.1)”, which i had left unchecked. Do you have it set to on in your setup?

Thanks,

Mike.


#7

Hi Mario (sorry for calling you Christian earlier!), Auralic suggestion seems to be working. I should have spotted it before, DS is now showing DoP, rather than PCM and I’m getting no problems in selecting tracks…that’s the problem when you let people like me close to high tech toys…

Also, conversion to DSF has worked and, you’re right, it’s seems to be tagging it better - the album is now stored under the artist rather than “#”.

Thanks again!

Regards, Mike.


#8

For now the DS does not accept native DSD over the USB input so you do need to check the DoP box in Lightning Server, or any other player software using a USB connection. Glad you got it fixed.


#9
Mike Marks said In the meantime Auralic have come back and suggested I need to check the box marked "DSD over PCM (DoP V1.1)", which i had left unchecked. Do you have it set to on in your setup?
Ah, I totally had forgotten about that. Yes, I had marked this DSD over PCM box. My DAC was the Oppo HA-1 when I had the Aries. Glad too that you got fixed it.

Well, I hope for an update that makes the DS DAC accept native DSD via USB. The ‘DSD’ in the display looks more cool than that ‘DOP’. cool