The long wait is over: The new Bridge II Code is live! (currently on hold pending a bug fix) v3.6.2

I just updated to 3.6.2 and it required additional power-cycle of DS to recognize bridge2 after upgrade.

Here are detailed steps i have followed in case PS Audio would like to follow-up on this:

  1. Preparation: power off DS , wait 30 seconds, power up

  2. In MControll i have triggered upgrade, waited few minutes so it finish up and reboot DS

  3. After the reboot (which tool quite longer than usually) MControl and Roon have been able to see the bridge, however on DS display input for bridge was not shown. Tried to switch to bridge via remote but the screen was default bridge screen without showing anything being player, it have shown on empty nw settings (should be dhcp) etc - just like DS would not communicate with bridge

  4. did additional power-cycle andthis time all works fine

@Paul please help me refreshing my memory - is MQA decoding limited to 192kHz? I am asking due to this - MQA says it’s 352.8kHz, but Roon reports bridge is decoding it to only 176.4kHz:

38

That has always been the case, though Paul mentioned the Bridge update implemented DSD DFF playback (sending dff64 via DoP) :smiley: yet I suppose that this limit has not been changed…

1 Like

thanks , so it is as i thoguht, just was not sure as MQA is one of those features i only try and then just keep spinning flac or dsd :wink:

Thanks for everyone’s patience.

Shouldn’t matter what DAC the Bridge is in. If you’re having an issue, please contact our service guys via email or phone on Monday. We’ll get you fixed up.

Hi Paul

I still cannot understand why you release new software on a Friday/Saturday, depending what part of the world you are in, and then if it does not work say give our service guys a ring on Monday, what are you meant to do on Saturday/Sunday if you want to use the DAC. why not release software at the beginning of the week then those who have problems can get instant help.

Mike

We release without prejudice to the day. We please as soon as it’s tested and ready because we figure people are excited and want it soon.

2 Likes

Hi Paul

I can understand your thoughts and eagerness to release the software but it is very disappointing for those who have problems to have to wait to get there problems to be fixed. Since I’ve had my DAC all software releases seem have been at the end of the week.

Regards

Mike

If service availability is of concern, wait until Monday to install the update.

Most of us would prefer to dive in, install the new firmware, and enjoy it over the weekend.

7 Likes

No pop for me, but MQA identified as “unk” as well. I’m not sure I’m hearing MQA from the Tidal selections that I know are MQA on my desktop Tidal app. Should I migrate back to Bridge version 3.3.3 which worked perfectly?
Thanks to PSA

All files are actually ‘Unk’ for me.

Thanks for validating this bug.

I downloaded the update to my DS jr and the bridge is no longer working. No ping no leds. I tried power cycling several times, reset the entire network but no luck. Fortunately the USB still works. Guess I’ll have to call support and see if they have any suggestions.

After playing FLAC, I went back to MQA and it now displays as MQA.

But FLAC files show as MQA as well.

I sent in an email. Just posting for awareness to those who haven’t yet updated.

Any Roon users having a problem after the update?
Update went fine, but after reboot Roon didnt see my DS Snr on the network.

Rebooted Dac several times , no effect.
Reset network bridge from touchscreen on dac, no effect.

Did full network reset (which usually fixes anything like this) and voila, there it was now seen in Roon.

Well…not exactly.
Sending music to DS doesnt actually do anything, play button in Roon is greyed out.
Also, when going imto DS settings in Roon, half of them are missing which ndicates the Dac/Bridge isn’t properly recognised in Roon after update.

Anyone else having similar issues?

After updating to the new bridge version no album covers with J river. After a powercycle DSD sr. covers are up and running. After 20 seconds when a song is playing, which is good. After playing 3 different albums the album cover stops again. Again a powercycle DSD sr. did the job, reset bridge not. With the old version I had never a cover problem. When this happens again and again I will contact PS Audio support. I don’t use Tidal and Roon so the old version was good enough for me. Never had an issue. Now my covers are gone and only will come back after a powercycle. J river works overhere for years always music and covers. Other users with the same problem???

Ronald

Cover art must be one of the most complex programming efforts to complete successfully ever (yes, a little snarky). I think there might have been only one version that’s worked perfectly going all the way back to eLyric and Bridge I. 3.5.1 isn’t perfect, changing data rates (16/44 to 24/96 for ex.) drops cover art on my system. Comes back after two consecutive same data rate songs. I’m going to upgrade to 3.6.2 right now. I’ll let you know how it works soon.

2 Likes

I have downgraded to 3.5.1 and album covers work now as it should be. Will contact PS Audio with this issue. It’s easy up- and downgrading with the bridge. Two years ago Dennis helped me when a version was not proper working on my DSD sr. He puts a lot of effort in helping me. Tried 3.5.1 with switching songs and after 20 seconds the cover is shown over and over again that is the way I like it. With 3.6.2 after showing 3 different covers it stops showing. And a powercycle DSD sr. is the only way to get the cover working. But it stops after showing a few covers. 3.5.1 works flawless the way I use it. Albums / songs playing with J River version 24.0.34

Well I updated to 3.6.2. Seems to work exactly like 3.5.1 regarding cover art. Any change in data rate drops the cover art until there are two consistent songs, cover art then comes back. I will keep playing 3.6.2 for now. I have the MConnect setup program and a choice of a bunch of different Bridge II versions through the link below:

PS Audio Update Link

1 Like

Any Roon users did the update yet?