The long wait is over: The new Bridge II Code is live! (currently on hold pending a bug fix) v3.6.2


#1

Thaks for your patience, the long wait is over to get the updated Bridge II code so the latest version of Roon works etc. The new Bridge code is live.

FW changelist between 3.5.1 and 3.6.2:

Updated Roon RAAT for support of Roon version 1.5
Updated Spotify library to 3.15a
Now supports first MQA unfold in Roon with RAAT changes. (MQA fix with Roon and DSP enabled)
Latest MQA library implemented
Improved DLNA/UPnP Device Search
Implemented DSD DFF playback (sending dff64 via DoP)

This update is, of course, entirely free of charge. Power cycle your DAC and then follow these instructions: https://www.psaudio.com/ps_how/how-to-update-bridge-ii/

Sorry it took so danged long but it’s been tried and tested till we’re happy.

Have fun and help us spread the word.


Popping sound related to Directstream Junior?
#2

Thank you, Paul!


#3

I’ve updated my support post on Roon forums for all to see there, thank you.


#4

Thanks Paul!

I updated the Bridge II in my DSSnr without any issues at all.

For me, the fix I was hoping to see (hear?) was the faint tick/click while playing DSD content. It’s early morning hear in Melbourne. The household is up. The washing machine and dryer are running. So not the best conditions under which to listen.
I’ve only played 10 minutes or so, but at this early stage I’m very happy to report that I haven’t heard any ticks!!!

Thanks again for your support :slight_smile:
Mark


#5

Thank you!!!


"Vinyl like” clicks and pos from BHK pre/250 when playing files via bridge
#6

Thank you. But on my Jr:

  1. MQA tracks from Tidal now display as ‘Unk’. I use the Mcontrol app. In the app they show as MQA.

  2. When the Bridge update completed and the Jr rebooted, there was an enormous POP into my speakers. No discernible damage, but maybe the directions should explicitly say not to have the amp on if this is a known feature.


#7

mmm. I spoke to soon.
I’ve had some quiet ‘me time’ to do some serious listening. For me it’s a case of Good News and Bad News.
The Bad News is that the random ticks are still there.
The Good News is that they seem less prevalent than the prior BridgeII firmware.

To ensure the ticks aren’t a side-effect of the SACD ripping process, immediately upon hearing a tick I went back 10 seconds or so and continued playing. Sometimes the tick was at the same point in the timeline but in a different position in the soundstage and/or at a different volume. Sometimes the tick didn’t appear at all at the point where it had previously appeared.

To be clear, I’m referring to the issue reported by many users. Playing DSD content from Roon over the network to BridgeII DS Snr/Jnr.

I notice that Paul didn’t specifically mention this issue in his release notes, so perhaps it hasn’t been addressed at all?

It’s such a shame, because when I listen to DSD content, I’m like the Psycho Killer: Tense and nervous - can’t relax :frowning:


#8

Pretty positive the ticks are Redcloud related and would not be addressed in a Bridge II update. I could of course be wrong.


#9

Great, I hope the delays between switching certain tracks since the last update are gone.


#10

I seem to recall it being said that the pops and ticks are Bridge II related and that PS Audio is working with the Bridge II vendor is South Korea to remedy it… albeit a bit slow for some of our tastes :wink:


#11

I think partly yes, bridge and partly answered here around post 159


#12

6 months or longer without a fix is a bit long. I listen to mostly DSD and find the Bridge II unusable because of the pops and ticks… there’s really no excuse for gear of this level to behave this way…


#13

I too have the DSD problem with the pops and clicks which I sadly am forced to deal with by lowering the volume on my DAC into the pre amp…the upgraded bridge II did not help


#14

That is another DSD issue that Ted has said should be fixed in the next FPGA release. That particular issue can be mitigated by reducing the DS volume to ~80.

The issue I am referring to is different. It seems to be specific to Roon steaming DSD content to the BridgeII.

For what it’s worth, I run my DS Snr volume at 80 just in case :slight_smile:


#15

After over two hours, my DS still reads “Updating…”

Last time this happened, I had to pull the Bridge out and send it to Boulder for repair.

Very much hoping that’s not the case this time.


#16

Interesting comments about clicks with dsd content. I only have two dsd albums - Wynton Marsalis’ Standard Time, which is wonderful, and plays flawlessly, and Billie Holiday’s The Lady in Satin, which is unplayable because of all of the noise and static. Because of the differences between the two albums I had assumed it had something to do with the download quality, rather than any hardware or firmware fault.
I have downloaded the latest bridge two firmware but it has made no difference to the Billie Holiday album sadly.
I await further comment on this topic with interest!


#17

And what means that for PWD DAC II owner?
I’ve actually not seen any update on my bridge II.


#18

I was happy to see the update hoping it would solve the popping problems (Directstream Junior).

The update seemed to go fine and the bridge output was still visible after it was done. After about 10 minutes i power cycled the DSJ (Rear button) and the bridge output is gone (no switch activity (no led), no ping etc.). Seems the bridge is corrupted.

This is the second time, first time time was after trying to downgrade the bridge firmware to 3.3.3 with MConnect (windows software). Jeremy helped and eventually it was sorted out and i placed a new bridge problem solved.

Hope this will not happen to anybody else.

Wil contact my retailer again, unfortunately he’s on vacation till 3rd of July ;).

Happy listening

PS still think PSAUDIO is doing a fine job providing updates, i suppose it’s just me having a stroke of bad luck


Popping sound related to Directstream Junior?
#19

PWD DAC II

In the meantime i started a second try with my android based mconnect app.
For my surprise here was offered a new update.
I started this process without any issues.
After update is finished in mconnect app i checked the status of the bridge on my PWD DACII.
He displays also the old firmware. With the rear button i made a new start.
Voila, update 3.6.2 is displayed and still working fine.


#20

@fdemello-2 how did it end up? is your bridge2 working?