Bridge II 3.6.86 is ready for updating

Bridge II update code has been released and is ready for folks to update with.

3.6.86 fixes DSD pops and ticks and will also improve artwork and stability issues.

For instructions on how to update your Bridge on either the DirectStream or DirectStream Junior, you can go here:

Here are the release notes.

  • Added function of Host FW download and copy to USB (uart command 0x85).

  • Avoid collision between uart and key (gpio) input.

  • The latest Spotify SDK version 3.55.23.

  • Implementation for Spotify’s new requirements and issues.

  • Fixed an issue for source switching between Spotify and others.

  • Volume Sync of Spotify via uart.

  • Keep playing Spotify music when device name is changing.

  • Integrated MQA library v2.4.0 build 1090.

  • Implementation for MQA certification requirements.

  • Integrated Roon RAAT v1.1.33.

  • Implementation for Roon’s new certification requirements, such as Multi-zone synchronization.

  • Improvements on network switching among LAN, WiFi Client, SoftAP and WPS.

  • Blocking incoming uart commands during firmware update.

  • Fixed an issue on sending events to MCU during FW update over WiFi.

  • Implementation for additional UART commands.

  • Fixed bugs and improved stability.

  1. Implementation of MQA’s latest build 1020. 2. Fixed issue for MQA output and codec info.

  2. Fixed bug on sending MQA type (MQA & MQA Studio) for Roon source.

  3. Fixed issue on sending album image from Spotify.

  4. Modifying the timing of sending album image from Roon TIDAL.


Well done Paul. thank you.


I have pinned this topic for two months so users will see this.

A new v3.6.86 all 24bit’s media indicates as 16bits …
[ PWDII + Bridge II ].

Valery …

First issue, maybe?:

My DS Sr. screen shows that firmware is up to date at 3.8.17 and does not allow for me to start the update process. I have cycled the DAC with a full power off and on, but same status shows on the screen.

Any suggestions…?

scotte1: I had same issue but here’s what I did to get the update (and some of this is from memory so …)

  • I powered DAC off and then on.
  • Waited for Bridge icon to turn green
  • Went to settings (upper-left icon)
  • Pressed Setup icon
  • Pressed Reset Bridge icon
  • Got a red “update” icon
  • Pressed that icon and update started

Good luck

I’m away from home so I can’t do the update for a few days, but I do see several references to Spotify which brings up an issue I have. I downloaded Spotify (free version) a while back and could not get it to play through MConnect, so I forgot about it. Earlier this week after another round of VTuner problems I tried Spotify in MConnect. It played, but regardless of the Player being the Bridge II it was playing on my iPad. Just didn’t sound that good. :upside_down_face: I looked for a setting to redirect to the Bridge, but found nothing. Is there hope this will update fix my problem?

Much appreciated. Most don’t realize how difficult it is to get all the devices to play nice without pissing one of them off.

Since this is primarily a bug fix,but is there any difference in sound quality ? As usually the case would be with PS Audio. Maybe i should try it myself and plug Bridge back in… :thinking:
I never had a problem with clicks and pops though.

I can never get Bridge to update via the DAC. Always use mcontrolHD. Works every time.

1 Like

Oops! Just noticed I had to pay for that app.

Had to recycle my DS Senior to get the update available indicator. Other than that upgrade went smoothly. So far so good.

1 Like

Can the beta testers get an update file for Mconnect (as automatic update doesn’t work for them it seems)?

The PSA Download section doesn’t show one.

Smooth update.

Definite improvement in loading of Roon/Tidal album artwork—almost instantaneous now.

1 Like

Tried the reboot three times. Still not update available. @Paul & Co.: Does the Snowmass firmware release installed on the DS Sr. matter? I can’t get past 3.6.17 bridge code and the software is up to date message on the firmware screen. I am going to leave the unit off for a while and see if the update shows up.

Worst case you can try to apply the bridge firmware update through MConnect. Had to do that once in the past for a prior update and it worked.

Thanks for the tip.


Did you find the new Bridge download anywhere?

Here it is:

1 Like