USB input on SGCD works maybe 50% of the time

Ok - that is what I thought, SGCD is just a DAC, and if Windows or OSX can see it, it should work. Here is the thing:

With Roon 1.7 the SGCD worked from my older Macbook, and a Windows 10 machine. Now with Roon 1.8, Roon does not see the DAC. Amarra does, and even OSX itself sees it. I think Roon is doing some additional check (or has a bug) and discluding the SGCD. On both a newer W10 Microsoft Surface Laptop I can run Amarra and connect to the SGCD, but not from Roon 1.8. And on my Macbook Pro running 10.13, Amarra and OSX itself can play to the SGCS, but Roon simply does not see it.

Do you have access to a SGCS and the latest Roon 1.8 - does it work for you?

I am sincerely frustrated with Roon’s help, people keep telling me the SGCS isn’t certified, and I was lucky it worked earlier…

I went with Roon, and have payed for the last 2 years because my Sony HAP worked sending UCB to the SGCD, but then Sony made a change “to work with more DACs” which killed working with the SGCD. SO, I still kind of suspect the USB solution in the SGCD has a flaw. Its been 30 years since I went to the Institute of Technology, and switched from EE to CS and went into consulting - so I have designed anything electronic in forever, but do IT and Cloud daily.

In Roon, what is in the list of play-to devices when you try to select the audio out device?

Amazingly with the latest Roon update, it can find my SGCD! Been listening to everything - including DSD!

Now I’ve got to tell some people in the Roon message boards that you don’t need a Roon Certified Endpoint to use a DAC

1 Like