Another P10 shutting down after the initialization screen thread

Hello everyone, I’ve found posts that are similar to my issue, but unfortunately the fixes do not seem to work for me. Here are the details:

  • I bought my P10 new around 8 years ago
  • Put it in storage in its original packaging around 5 years ago
  • It was working fine when I stored it

When I flip the ON button, the screen indicates that it is initializing, but then it powers off. When I take the top off and try it, I can see a few green lights on a circuit board after it seemingly powers off, so something is happening.

I checked the fuse with a multimeter and it is indeed passing a signal.

The little blue emblem on the front of the conditioner never lights up, so I think that might be a clue. I’ve tried the fixes listed in this thread to no avail: P10 initializing for 5 secs and shutting down

I stored it in its original packaging and it’s never been dropped or abused. Could storing it for 5+ years have caused any issues?

The only think that I can think of is, when I was moving it into position, I accidentally grabbed the corner of the conditioner where the screen is and pushed in a little on the screen and felt the screen flex. That said, the screen looks perfectly fine when it is initializing.

I’ve never updated the firmware, so I think that’s probably the best place to start. Does anyone have a firmware file the can share?

Any ideas would be greatly appreciated!


I had exactly the same issue… like exactly…

Just power on at the back, and within the first second immediately and constantly press the blue PS Audio button… it should enable the machine to not switch back off.

1 Like

It sounds like it’s just booting into standby. Pressing the blue logo button should turn it on completely.


Hi guys, thank you for the fast response! Unfortunately that doesn’t seem to work for me. When you power yours up, does that little square button on the front light up at all? Mine doesn’t, it stays dark.

Did you press the blue button while turning the back switch on as suggested?

The timing matters as I understand it, and it would be normal for the blue button to not light up until you press it in quick succession to flipping the switch on the back.

1 Like

Phil, firmware is downloadable from the PSA website - Support Downloads Firmware Archive, see:

1 Like

Hi everyone, thank you again for your replies. I’ve tried the little blue button in every possible combination I can think of with the main power switch with no luck. Thanks Danofesherintheuk for the quick link to the firmware. I finally have time to give that a shot. Fingers crossed! I’ll report back.

Good luck!

Okay, problem solved.

I couldn’t get the firmware to run- it kept shutting down regardless of any combination of SD card and button-holding.

So, I decided to carry it down three flights of stairs and try an outlet in the kitchen that is a new line, thinking that maybe it was a power issue. Nope.

Finally, I decided to open it up again to disconnect and reconnect every wire that was on a harness. I tried that before, but decided to give it one more chance. I must have missed a wire last time because this time it fired up!

Thanks everybody for your time and suggestions!


Well done