Bass all of a sudden missing


#1

2 days ago my system sounded great. Today I tried playing a cd with PWT and it sounded like it had no bass. Both channels sound the same. I switched the CD player to a different I2S input, nothing changed. I tried playing from my bridge II still no change. I have Torreys 1.37.

Any ideas?


#2

Do you have another source you can try?

If not, I suggest loading different firmware and giving this a listen.


#3

Before changing firmware try powering off and back on with the back switch if you haven’t already.


#4

How many hours do you have on your DS?

I found burn in is a rollercoaster with the DS sound wise.


#5

Thanks for the replies. I have power cycled the unit with th rear power switch. I tried playing music with both I2S inputs plus I played a track from my hard drive via the Bridge II.

This is not a subtle change. The level has significantly dropped and there is NO bass.

Im hoping this is caused by software corruption and not a hardware issue. I think I upgraded to DSD about 8 months ago.

Can anyone tell me how to force the unit to reload Torreys?


#6

Have you tried phono or another CD player directly into your preamp/amp?


#7

To reload Torreys you can first load Yale or another earlier firmware and then load Torreys again. Use a clean download and reformat the SD card if possible.


#8

Are you sure your spouse hasn’t turned the subwoofer down? That happens in my house, though the cat gets the blame.


#9

I don’t use a preamp and have 1200 watt mono blocks.

I will try rebooting Torreys