Bluetooth skipping


#1

I recently purchased a Sprout and love it. However, both my wife and I have Retina macbook pros, and both of them experience intermittent brief audio skipping when streaming to the Sprout with both Itunes and Spotify. USB to the sprout is fine. This is probably a mac problem, but since both of our <1 year old macbook pros do this, I though I would ask if anyone else has this problem. It’s happens with both of our laptops, but intermittently, and without a clear pattern. Audio to headphones and macbook speakers is fine, including spotify. Machine specs: OS 10.10.4., 16GB RAM, 1TB solid state drive. Thanks for any suggestions.


#2

Welcome, graywacke1

There have been some past discussions of using a Mac with Sprout. I am neither a Mac user or have a Sprout so I am unfortunately of zero help. But someone who is actually useful should be along in a bit.


#3

I use a Mac streaming to Sprout without any issue as long as the computer is in close proximity. If I pull away too far, sometimes even a matter of a few feet it starts to skip. I wonder if this is a similar issue? What’s the distance?


#4

Basically sitting on my couch in front of Sprout, but about 15 feet away. Is that too far?


#5

No, shouldn’t be. Hmmm. Stumped. Does it correlate with anything? Any particular type of stream?


#6

No, but if the concomitant wi-fi download is very heavy (like reopening a web browser with previously open windows), it seems to add to the skipping. So this could be wi-fi interfering with blue tooth - but we changed wi-fi router bands to 5Ghz and that didn’t help. Or it could be processor/drive demand, but it happens with two different <1 year-old retina mac book pros (3.1 GHz Intel Core i7) with solid state drives and 16 gb RAM, so it’s hard to see how drive or processor load is the issue. It happens with Itunes, Apple Music, and Spotify, but less so with Itunes, which makes me think that wifi is involved. Paul, are you running Mavericks? Apparently there are some bluetooth issues associated with Mavericks.


#7

I learned something about this issue. If you hold down the option key while clicking the bluetooth icon, an RSSI signal strength value is shown. Mine was in the poor range with Sprout sitting on my cable box. I moved it a few times and now it is in the good range. Hopefully that stops the skipping.


#8

Aha! I should have thought of that. Setting Sprout near another radiating piece of equipment may have an effect. Skipping usually means trouble receiving the signal but since you were so close… good detective work!


#9

I am having the same issue with my mac, less than 10 feet and Bluetooth is unusable with a macbook retina.

My phones have the same issue, even a few inches from the sprout. Any suggestions?


#10

I would start with the ideas already presented: possible RFI overload from other nearby equipment. Move the Sprout as far away as possible from other equipment, particularly network routers & switches, computers and cable TV boxes. There may even be a cable in the wall causing issuse, so just try moving the Sprout even if there are no identifiable possible interfering devices within 3~5 feet. Also, try moving all wires connected to the Sprout as these could be acting as antennas bringing interference into the Sprout.

J.P.


#11

Check this out. The stable high signal is my new macbook pro sitting on my chair without me in it. The drop in signal (which results in skipping Sprout playback) is what happens when I put the macbook on my lap when sitting in the same chair. Now how do I fix it? It is worse with my knees up, but still bad without obvious line-of sight blockage from my leg. Any ideas?

bluetooth-signal.png