BubbleUPnP volume vs. DS DAC volume - a theory


#1

I think I’ve finally puzzled this one out. The issue is that when using the DS with BubbleUPnP, with it setup to control the volume of external renderers, volume control sometimes works, and at other times, has no effect.

I had thought that this loss of sync was caused when I used an IR remote to directly control the DS volume, but at times I’ve gone from using the remote to using the Bubble volume control, and it worked fine.

I now believe that the issue is simply time-dependent: if you try to set the volume from the Bubble slider several times in a short time, the DS will usually stop responding, and will no longer work from Bubble for “a while”. A secondary symptom of this is that the DS display will no longer visibly blink off and refresh a few seconds after you try to change the volume from Bubble.

If, when in this state, you leave Bubble alone for “a while”, it will often regain the ability to control the DS volume. I have not yet determined how long “a while” is, but it’s measured in minutes.

Can anyone else confirm or disprove this theory about the issue, or have I lost it completely?


#2

Your observations very much correlate to mine.

I am using Bridge2 with Minimserver proxied via BubbleUPnP server as OpenHome device and I’m using Linn Kazoo as my controller.

As in 99% I am using preamp to control the volume I can live with this, but if one does not have preamp it can be annoying.


#3

Unfortunately, I seem to have disproved my own theory - the Volume disconnect does not appear to be reliably time-dependent, and I can’t figure out a reliable way to get it to connect again. Like maniac, I wind up using my universal remote for Volume control.

Sigh.


#4

This might be a bridgeII issue and I will do some testing before we release a final Roon version.

Dennis


#5

My latest theory. This time I find that not only can Bubble continue to operate the Bridge II volume, but even recovers control of it after use of an IR remote.

If someone could please confirm: if you are having issues with BubbleUPnP volume control over a Bridge II, tap the hamburger menu icon at upper left, tap Settings / Control / Volume step and check the value of Volume step. If it is not zero, set it to 0 to disable it. As far as I can tell, disabling this works around the issue, and you should be able to reliably control B2 volume from Bubble on the Now Playing tab.

I can reproduce all kinds of problems with Bubble control over B2 volume with the Volume step set to 4, but it works as expected when the Volume step is disabled.

(I think.) Please verify I’m not imagining this?


#6

I tried putting volume steps to zero and it works ok for me but I had to change volume control mode from buttons -> slider. Volume steps 0 works only when volume control is set as slider. Normally I am using volume control set as buttons. With volume steps set as 2. By this way I can control volume better compared to slider mode. I have also noticed that if volume is adjusted from bubbleupnp fast (volume control as button mode), sometimes volume sync between bubble control point and ds dac is lost and it recovers after some time or if renderer is changed from b2 to local and back to b2.

With network analyzer I have checked that even the ds dac didn’t react to volume control, those volume control were sent to ds dac via network. Seems like some kind of B2 issue.

I have not checked with network analyzer but if volume control in bubbleupnp is set as slider and steps > 0 then it might happen that bubble sends volume control messages more quickly to ds dac, and it causes then issues seen.

Can you compare if there is any difference in volume control operation if slider or button mode is used.

As a general observation and feeling I think bubbleupnp and b2 worked little bit more reliable with Yale FW installed.


#7

I don’t have the described issues with the volume synchronization between BubbleUPnP and Bridge II.

I am using the hardware buttons with volume steps set to 1 and the slider disabled. When I was using a beta version of Torreys and had no SD card in the unit then I had synchronization issues, they were gone when the SD card was installed again. Do others have this experience as well?


#8

Same here, never got problems with volume control in Bubble with sd card, without I lose volume control connection


#9

I’ve got the issue with an SD card in the DS.


#10

This evening I also had the issue with the SD card in. It was also the first time I played some dsf files, don’t know if this is somehow related. After a restart of BubleUPnP volume control worked again. Will keep an eye on it…


#11

Hi,

I have same configuration but with Bridge 1.
Either from Linn Kazoo or the remote, if I change the volume too quickly, it freezes as Elderick mentions it.

Very annoying…

I f anyone has an idea ?

I’ll try to reset the firmware of both de bridge and the DS in the meantime.

Regards.


#12

I don’t use the Bubble UPnP volume slider, but I did have issues with the track playing time working reliably.
The issue was solved by loading BubbleServer on my NAS and creating an open home renderer for my renderer.
I think this places the processing load entirely on the NAS, which has more power to handle the function.


#13

Hi,
I also use BubbleServer on my NAS with an open Home render for the DS/Bridge, along with Minimserver.
Linn Kazoo completes the system.

The firmware update / refresh on the Bridge I seems to have fix the issue.
Still, the LinnKazoo volume control through the OpenOpen render is “erratic”…

At least I have not faced the “freezing” issue while playing too much with the volume on the DS remote…

Thx


#14

I do not know if this will make a difference or not, but there is also Linn Kazoo Server that I believe installs on your NAS.