Direct Stream requires frequent reboots


#1

Approximately every other day my DS has to be rebooted.

The symptom is no sound and the front panel shows no lock to the source.
A power reset cures the problem.
This never happened before the 1.21 upgrade.
Any thoughts?

#2

I need to reboot my DS everytime after I’ve shout down my notebook. The USB driver is not detected before I make a cold start with the DS. This is the case since the upgrade from PWD to DS, with any FW I used. A little bit odd, but I can handle it. The SPDIF works well but my bridge is gone since weeks and I can’t recover it. But since I prefer USB over bridge for convenience reasons, I don’t care that much about the bridge. Hope the new bridge will combine the ease of use of the USB with the SQ of the old bride (at least). If not, I’ll go the Auralic Aries way, I guess. I want windows out of my stereo…


#3

I forgot to mention that I do not use the bridge or USB.

I only use the toslink and coax inputs and still it requires reboots.


#4

Yes this is why I packed up my Mini couple months ago and went just to the Bridge. I have complained in the past about its connection drops but to my pleasant surprise it’s been very stable of late and seldom have had to reset. No apparent reason but now I’m enjoying music without having to get up and troubleshoot the latest disconnect several times a night, 1.2.1 helped a lot too. 103_gif


#5
aliaswolf said If not, I'll go the Auralic Aries way, I guess. I want windows out of my stereo...
The reboot is not a problem present with the Aries.

Another nail in the PC coffin (even if a new Mac mini is coming). I get reminded every day how smart move it was to invest in the Aries…


#6

This is still happening and I use SPDIF inputs only.

Ted, you thoughts on what is happening?


#7

You also mentioned it never happened before the last update?

If so I’d redo that update and see if it helps, but I don’t hold much hope there.

All of the problems I remember that require reboot to get sound on non-bridge non-USB inputs are on the OS side - With those inputs the DS is a simple receiver and provides no feedback. Also, in general, if the PIC dies the FPGA keeps playing but the display obviously freezes (or worse.) I’ve never seen something cause the FPGA to not play. Also if the FPGA wedged, you’d hear a big thunk as the output would freeze at one rail or the other.

If you have a spare DAC of some sort lying around that you could just swap for the DS when this happens, it would be good to know whether that DAC plays (with no touching of the PC or whatever.)


#8

I have the same problem. My DirectStream requires frequent reboots to find the input. I only use coax/spdif for my streamer (coax otput) and toslink (cd-player). There is no bidge. Any idea what to do?


#9

Welcome, moge21!

What are you using as a player/streamer?

Have you tried loading a different version of the firmware than you are currently running, and then reloading your preferred version?

It is worth trying shutting down and unplugging the unit from the wall for a couple of minutes, and plugging it back in.


#10

Thanks for your response. As a player/streamer I am using the Pro-Ject Stream Box DS net which I appreciate for its internet radio (vtuner) and the ability for showing album covers and readable titles from my listening position.

I have tried to unplug the unit from the wall but with no success. The DS does not recognize the inputs s/pdif (coax) and toslink (cd-player is a Marantz Pearl Lite). They only work after rebooting the DS. This is very annoying.

I hope the unit has no error.

I would appreciate any other suggestions very much.


#11

Have you tried reloading the firmware as I suggested?


#12

I just tried to reload an old and then the newest firmware but without success. Only sometimes at the beginning the light switches between red and green but then it keeps red (no connection).


#13

Is the only think you do to get things working is to reboot the DS - absolutely nothing else?

I’ve never seen the DS stop playing a S/PDIF stream and require a reboot to get going again. Especially since you mention TOSLink as failing too. There’s nothing I can think of that would cause TOSLink to stop and require a reboot. But there’s a remote possibility that non-TOSLink inputs could be being affected by ground differentials, etc.

If you don’t mind running an experiment, can you disconnect all other inputs to the DS other than the TOSLink and then see if your problem persists?


#14

@ Ted Smith:

It is not to be understood, that I lose contact during operation. The faulty connection to my inputs (coax and toslink) only occurs when turning on all my devices. To hear the first notes, I have to reboot the DS. Only at the beginning I sometimes see the switching light between green and red. After rebooting, I have no problems in operation. To turn on all my devices with its right inputs with only one button, I used a universal remote control. I have now tried to turn on all my devices manually (at the end the DS). This worked and the DS found the Inputs (I did not know how nice the color green is). Can the order of turning on all the devices affect the DS? I hope this will work in future, too, though I would love the comfort of an universal remote by switching on all my devices with one button.

(footnote: Sorry for my English)


#15

I actually suspect that it isn’t the DS, but I don’t know enough about the rest of your system to make a good guess as to what it is.

At times using a universal remote to turn a lot of devices on all at once sends a lot of IR codes back to back and sometimes the blast of IR codes confuse some of the devices. In my remote I can add small pauses between successive codes and sometimes that’s what is required to get everything to work well.


#16

Based on the conditions you describe, I think what is happening is your AC voltage is sagging while your other devices start up all at once which would momentarily affect the operation of your DAC. Try plugging your DAC into another outlet on a different circuit.


#17

^^^

Clever suggestion. Good deductive thinking. 41_gif


#18

@willcycle:

I think you did it. The right thinking and answer to my problem. I followed your advice and that might be the solution. If I were a woman, I would send you thousand kisses.

I will see more the next days and I hope that now I can relax in the stream of Music.


#19
I gave up using my video system with the Direct Stream because of the frequent reboots required.
Only my PWT is now hooked up to the DS with toslink. It no longer requires reboots.
The video system used a Zektor HDS4 switcher that I used to select which source sent coaxial spdif to the DS.
An OPPO bluray player and two Scientific Atlanta 8300 cable boxes were hooked up to the Zektor switch.
The loss of lock would usually happen when a different source was selected on the Zector switch.
A reboot would then bring the the audio back.

#20

Mine has been running continuously for 7 days, uninterrupted. Source is an SOtM sms-100 (USB)

There are some high rez files in my collection as well as DSD and DSD128 so there is some high bandwith usage regularly.

Can still hear the music when the amps are turned on ;o)

DS looks stable in these conditions…