Directstream firmware

Just recently set up my Directstream from being stored for months.
It has the snowmass firmware Firmware 3.0.5. and Bridge 3.6.86 installed.
Roon no longer recognizes the unit. Roon recognizes all other equipment that is on the Network.
I have tried a new network and every possible restart possible.
Any clues or updates I have missed. It will also not download the new Windom.

Make sure your Bridge card is getting an IP Address. I know mine keep loosing it’s IP Address even though I have mine set for Static IP Address.

Also remember to put the SD card in upside down (pins uppermost).

Tried that often, nothing happens. It does show the address.

The card is in correctly, still nothing

Remove and reseat the Bridge II board?

Thanks. For some reason its now working correcting. I think it heard me that going its going to the GoodWill


Maybe off topic but:
My directsream with bridge II shows lately a red network sign on the display.
But i can play my files over the network without any problem.
What can cause this issue?

Same here. I need to shut it down and turn on again to listen to CD.