Bridge II not showing up

I have the Directstream DAC with The Network Bridge. Sporadically it cannot be found by my UPnP apps like Mconnect. Also the bridge connection is red, but will sporadically turn green and show as connected, but is connected to my router via an ethernet cable. I have tried everything I can think of, rebooting the DAC, rebooting my router, etc all to no avail. Can someone please tell me what I am missing? I am beginning to believe the Bridge card is bad.

Have you tried swapping out the Ethernet cable?

Yes, I have changed out the ethernet cable also to no avail.

I saw the red network icon when I forced my switch to set the Bridge to 1000mbps. I was trying to find specs to see if the card supports that rate, but it doesn’t when I set it. It works on autonegotiate or forced 100mbps. I still haven’t figured out why my bridge has been sputtering… it plays files via roon, stalls, then plays again.

The red icon is a physical network link indicator, I think. You could also check your routers port light when the bridge turns red to see if the physical link is down.

Hi Vee, Thank you for your helpful suggestions. I have checked the router, since now the light remains red constantly, and the port appears to be working fine.

Sounds like you might need a replacement.