DirectStream Memory Player - Won't play SACD'S?

Hey everyone - I have changed the settings in the menu and have tried a dozen different SACD’s but it only ever plays the CD layer. CD’s play fine as well… Any tips or suggestions?
Is there a factory reset I should try?

Thanks in advance!

Have you tried powering off the unit? I had the similar issues a few times and power off and on solved the problem. Sorry, my unit is PST.

Just to confirm: you do have the DMP hooked up to a PS audio DAC via I2S. If not, it will only play the CD layer.

1 Like

You must use the i2s connection and use a PS Audio dac. Othervise you have transform the DSD data on the SACD to DoP (DSD over PCM) and send it via AES/EBU (not coaxial or toslink) to a dac that can recite DoP via AES/EBU and decode the DSD.

We recently had a long threat about this, I’ll see if I can find it

Have a look at this link to another recent thread.

I the second post, I develop the answers and solutions to your question more in depth.

You might find a good solution or a good work around in the information

1 Like

Hey DMP Going to DSD Via Is2

yes I do

If this is happening on hybrid SACD/CDs, try cleaning the lens. You can use a cleaning disc with brushes on the playing side, but you’ll have better results removing the unit’s lid, removing the top of the drive, and gently brushing the lens with a clean cotton swab. Do all this with the unit unplugged, of course. Take the opportunity to blow out any other accumulated gunk in the unit.

If this doesn’t work, the laser assembly may be failing. Fortunately, these are relatively inexpensive and fairly easy to replace. There are other threads on this forum detailing replacement of these assemblies. Good luck.

Hmmm good idea. Thank you I will check that out!