Distorted sound using DS USB input


#1

I’ve got no idea where to post this, so Mods please shunt it to where it needs to go.

1st attempt at USB playback on my new DS sound is grossly distorted, how do I upload a Quicktime video to this post to demonstrate the issue?

Using Macbook Air OSX 10.9.4, PS Audio driver correctly identified in system sound preferences, green spot showing on the USB logo on the DS display, using VLC as the media renderer…

[Post moved to its own thread. Elk]


#2

While I suspect a video is not going to assist in remedying the issue unless the display is exhibiting something truly untoward, just click on “Add Reply” and then “Attachments” at the bottom of the editing screen. The forum will accept qt files.

You are not trying to send a DVD, Blu-Ray or any other video source to your DS via VLC are you? You are having an issue with a pure audio file(s)?


#3

I tried attaching a QuickTime movie to the post before but the file extension was not allowed. Trying to play a FLAC downloaded from HDTracks, the sound is very distorted which is well illustrated in the QT video.


#4

The qt file extension is allowed. Is this what you are using? You can also zip the file as zip is another allowed extension. As a practical matter, I doubt this will help in any event unless the distortion is somehow unique and telling on its own.

What is the resolution of the file? Are you certain VLC is set up to play it properly? Have you tried playing a 44/16 Redbook file?

What driver are you using? What output choice have you selected in VLC?

Have you tried another player, such as Foobar?

Don’t forget trying power cycling the computer and DS, as well as a different USB cable. Odd little issues can often be resolved this way.


#5

We believe that you are getting distorted sound. The likely source of the problem is the configuration of your computer or the playing software. I’m not a MAC guy so I hope some that have experience with getting a MAC setup correct will help.

Tho I don’t think it’s your problem, a problem that caused MAC users grief was that the initial release of the software for the DS didn’t work with the defaults of the MAC sample rate conversion. In general you don’t want the MAC to be doing sample rate conversion, but most first time users haven’t gotten that far yet. You might still want to verify that the version number of the FPGA in the DS is 0.61. To do that press the little gear in the upper left of the DS’s screen and look at the upper right side for the FPGA version number. If it’s not 0.61 we can point you to instructions on how to download and install the latest software.

The most likely reason for distorted sound is some sort of DSP, automatic volume leveling or … is configured in your playback chain. Perhaps it’s even as simple as the volume being above 100% somewhere. A quick test is to turn the volume down on your computer and see if it makes a difference. A more precise test is to verify that your computer is set up to send audio in a bit perfect manner to the DS. But that takes a little work and at this point is likely to just say that you don’t have a bit perfect configuration at the moment which doesn’t necessarily help in figuring out where something is wrong. Here are the instructions (unfortunately written more for a windows user, but it should be enough to run the test) :http://www.psaudio.com/ps_how/how-to-run-a-bit-perfect-test-with-directstream/

Some information on what software you are using to play audio would be helpful (perhaps I missed that). Also what other software you’ve tried (if any.) And if lowering the volume on the computer helps…


#6

You might also try converting a file to AIFF (Max is a good tool for this; just google Max Mac; it’s free) and playing it on iTunes (which does not support FLAC). Go to Audio Midi Setup (in Applications/Utilities) and make sure the output is set to the DS and the sample and bit depth are the same as the file (e.g., 44.1 kHz/ 16 bit for redbook/CD). You can also install the BitPerfect Application (available in the App store although that may not be the latest version), which automatically takes care of the sample/bit settings (actually bypasses Audio Midi Setup). It’s only $10. More details are in Paul’s article on how to create a Mac Mini server. (BitPerfect only works with iTunes on the Mac and is not to be confused with the bit perfect test Ted mentioned. You can run the AIFF bit perfect test file using iTunes like any other file, but turn down/off the volume.)


#7

My video grab is an MPEG-4 file…it might add some understanding, or might not…

MAC iTunes > DS is working…

eLyric is seeing the DS but won’t play anything…

VLC I’m getting gross distortion during playback…

Let me look into it’s configuration…

My DS is 45 hours into break-in. At this stage I can only pick the most subtle differences when switching on the fly between source player analog direct to pre-amp or digital via the DS to pre-amp but most of the time I’m just guessing which one I’m listening to. I have read some owners in Australia reporting a break-in period of 1000 hours bringing required.


#8

VLC has a myriad of options for the audio setup, you might have to use the show all settings radio button to get to advanced settings mode to see the culprit: I hope not.

I appreciate that VLC lets you have a volume over 100%, but that may be the problem you are having.

In the simple audio settings, unless you have a reason to do differently I’d turn off , set replay gain mode to , set Dolby Surround to , turn off and perhaps set the <always reset audio start level to 100%> If that fixes it you don’t need to waid thru the many, many audio settings in advanced mode.

Since iTunes is nominally working you want to run the bit perfect test I mentioned earlier to check that there’s no subtle processing going on that might be affecting sound quality.

I’m sure you’ll hear changes from 45 hours to, say 100 hours or perhaps 500, but I certainly wouldn’t wait for 1000 hours to just sit back and enjoy the DS. On the other hand, until you can reliably sent the bits out of your computer without modification (at least when you want to) you don’t know whether you are hearing the “real” DAC or the results of who knows what processing.


#9

Last night when I configured this I’m pretty sure in the Mac System Preferences > Sound > Audio output settings I saw PS Audio USB 2.0 Audio output, which was selected. During playback (Cat Stevens Tea For the Tillerman downloaded from HD Tracks) the DS display was showing PCM/356K/24bit and playback was grossly distorted.

This morning in the Mac System Preferences > Sound > Audio output settings I have set “internal speakers” and in VLC Audio Output = PS Audio USB 1.0 (yesterday I’m pretty sure it showed USB 2.0). Playing the same content the DS display is showing PCM/96K/24bit and playback is not distorted.


#10

Have you tried Audio-midi set at 192/24 max. Also tell the OS to use the PS Audio as the playback device and make sure that in Preferences > Audio the Directstream is selected. The PS Audio should show as USB 2.0


#11

I don’t believe you have a copy of Tea for the Tillerman at PCM/353.8K/24bit. If you were trying to play a PCM version of Tea for the Tillerman then something was upsampling it to 352.8kHz and perhaps doing something worse. As alcarp alluded to the default is to upsample everything to 352.8kHz which will work if you have the latest firmware in the DS, but it won’t if you don’t.

If you were trying to play a DSD version of Tea for the Tillerman then either your system was converting DSD to PCM (badly) or it wasn’t setup to use DoP to send the DSD or it was packing DSD as DoP but something downstream was playing with the bits. FWIW AFAIK VLC doesn’t do DSD (via DoP or not.)


#12

My DS has 1.1.9 loaded…

The current config is showing USB 1.0 in both the Mac system audio preferences and VLC audio output menu…

Tea for the Tillerman content was purchased as a 192kHz FLAC and the typical file size for each song is about 130MB (if that’s any clue to what it really is). The DS is connecting as USB 1.0 and reporting 96kHz, so obviously some processing within the VLC needs to be un-ravelled.

When I first attempted connecting the DS to the Mac it wouldn’t connect, then I tried a different USB cable and it connected, so obviously the cables are having some influence on the outcome.

I’m just about to release the DS onto a pair of Magico S5 this afternoon, but not at my house (unfortunately, I only have Wilson Sophia v3).


#13

If you haven’t already done it, as a test, try a standard (cheap) USB cable. Any legal USB cable should work: some “audiophile” cables don’t meet the USB specs and thus only work in some combinations of systems, DACs, hubs, etc. and in extreme cases seemingly only at certain times of day. Also if you are using a USB cable (or string of passive cables) that’s longer than 5 meters it is not to spec and it will fail in many setups.


#14

What does it say in Audio Midi Setup (in Applications/Utilities)? In general you should probably be using that instead of Preferences/Sound unless you have software that is bypassing all of that. The two should show the same devices but Audio Midi Setup has sample and bit depth settings and those settings will result in resampling unless you have software (like BitPerfect, Audirvana, Pure Music, etc) that bypasses it.


#15

Audio MIDI setup says USB 1.0

I’ve enlisted some local help to come over and assist me with this (not difficult finding volunteers as my DS is probably the only one within a 1000 miles of here!).

Computer audio is not my thing, I primarily purchased DS for redbook CD via coax input however I bought a stack of HD Tracks when I first had the PWD2 here that I would like to put through the DS.