DSJ USB not working

I have purchase DSJ for 3 years and very satisfied with it. But never tried its USB function. Yesterday when I pluged it with PC,MAC and Pc laptop by USB, all failed with same notification:
Setup requires that the device is plugged in…
I changed with another USB cable and made sure that the cable was fully plugged in the hole. But all were failure. PC found there was a USB machine connected but nothing happened.
Can PS help me to solve this problem?
Do I need to reset DSJ to earlier version? Now I use the latest widom version.

By the way, I did put DSJ in USB in mode.

I have DS DAC. Only tried to play from USB from iPad/iPhone. Never try that on PC/laptop (I do not have Mac), but find this Info below from user guide. Maybe driver update will help.

“…If you are using USB, make sure both the computer and DirectStream are connected and powered up. USB also requires a driver to operate properly. Mac and Windows 10 computers have the driver built in. Windows 7 or older PC’s require the PS Audio driver to be installed. Download the driver from our website at http://www.psaudio.com/wp-content/uploads/2014/02/PSAudio-USBAudio2.0DriverLatest.zip…”

What connection method were you using previously and what player are you using on the PC’s?

How long is the cables you’re trying to use? The computers might not be recognizing it because the cable is too long.

Depending on how he had it connected previously it may just be a matter of switching to the PS Audio USB driver in his player.

The cable is only 1.5 meter long. The problem is I can’t install the USB windows driver on my pc, DSJ told me no device found.

Tho I haven’t done this with recent Windows 10 releases this should still be relevant:

I have done exactly as “How to fix…”,but can’t get the driver to install.All ended with"
Setup requires that the device is plugged in. Please connect the device you want to install and make sure it is turned on. If your device is currently connected, please unplug and replug it."
But my pc system did notice a USB device connected.
So maybe PS can send me decompressed USB driver files for me to manually install the USB driver.

The PS Audio USB driver is in the downloads section:

I downloaded the USB driver,but the installation package didn’t allow me to go on as it didn’t found USB device plugged. But my system noted USB device was plugged.

You may need to call PS Audio support (or email them) but if you follow the instructions I linked to above using this download you will probably be fine. Don’t skip any step.

Thanks. Maybe I should try Matrix X-SPDIF 2 to skip this USB. From reviews of this forum,this is quite good option.

Mine does the same thing asio is not recognized in audervana was told usb needed update but pc does not see DSJ, IT Still plays pcm but i want dsd my 900 hundred dollar dac plays all formats with out a bit of trouble makes no sense

I’m a little confused here. You mention the PC doesn’t recognize the DAC but you’re still able to play PCM files?

When using Audirvana and selecting asio ps audio DsJ is not found if you select wasapi or kernel streaming its available ,but only displays pcm as the output from kernel or wasapi ,hope that clears things up

Hmm, I’m not an Audirvana expert so I can’t say for sure what’s going on. Have you tried any other SW and tried to select the asio driver?

Well tell me what you use what are those settings, i have tried j river but cant even figure that out without some guidance ,ill admit im kinda p.c Stupid, but ive got great ears for great audio.i have tried the smple tidal app on th p.c. but still no dsd ,windows media player, no dsd maybe i should try roon again