PWD USB Driver Installation Issues


#1

Hello,

I know that this topic has been discussed here on this forum for a lot. I have read as much as I could on those threads and responses. And yet, I am not able to solve the issue I am having with my PerfectWave DAC II. I apologies for making yet another thread, but I did not see any other way…

So recently I bought PWD DAC. I hooked it up with CD player and it plays very well. No issues. I then hooked up the DAC with my computer and that is when the issues started. I realized that I needed to install a USB Driver. So I went ahead and downloaded the USB Driver 2.0 files on my laptop. I extracted all the files in a folder. Then clicked on “Setup” file to begin the installation. A new window popped up and asked my to shut down all other applications for more efficient and troublefree installation of the driver. I made sure of it.

Then it asked me to make the connection between the DAC and computer. I did that with USB cable. Nothing happened. It displayed a message that unplug and replug the device. I have so far tried rebooting the computer and DAC many times. I have gone through three different USB cables including a printer USB cable. The computer I am using has windows 10. I have tried three different computers including one with windows 7. I have also made sure the status on firmware which is 2.9.7.

What else can I do… The DAC is an excellent product. I really want to enjoy it with my media server (windows). One thing, I do not have the bridge. Does that make any difference? Any help, I would really appreciate.

Thanks.


#2

By skipping the initial install of the correct drivers the OS now thinks the default USB audio drivers are good enough. There’s a how to on correcting USB driver problems: http://www.psaudio.com/ps_how/how-to-fix-usb-connectivity-issues-with-dacs/ At step 4 you may need to also use the device manager control panel to remove all drivers for PS Audio products. Open the device manager control panel, on the View menu select “Show hidden devices”, then look for all PS Audio devices. (There’s probably at least one under “Sound, video and game controllers” and maybe one or more under “PS Audio USB 2.0 Audio Devices”.) On each right click and select “Uninstall”


#3

I recently when through this whole thing with the USB driver.

I was advised to uninstall first through the Programs and Features control panel app and then check in Device Manager (using View Hidden Devices) to see if anything was left. Maybe it’s OK to start uninstalling from Device Manager; Ted knows more about USB than I ever will, but I don’t think it can hurt to start from Control Panel.

Then I used a utility that checks for leftover bits of installed programs that the uninstallers miss. There are several; I used one called Revo. It found two registry entries for PS Audio that I had it delete.

Finally I ran setup.exe by right-clicking and choosing Run As Administrator. That shouldn’t be necessary, since Windows was asking me for permission (which I gave) anyway.

At this point I was able to install the driver. I’m not sure whether it using Revo or the Run As Administrator or the combo that did it. Hope this helps.

Edit: the Bridge connects via Ethernet, not USB, so having or not having one makes no difference to this issue.


#4

Thank you guys for your responses. And I followed up these leads. One thing I noticed is that under Device Mangement>View Hidden Devices> Sound, video and game controller, I did not see anything installed related to PS Audio. There was no file on PS Audio.

I also downloaded Revo and ran that to eliminate any registry related to PS audio name, and there was none.

I followed the direction from the reference that Ted provided, tried to connect the DAC and computer and still the same issue… I will try one more time by resetting my computer to previous date memory settings (I will revert back by about a month or so) and see if that helps.

Thank you.