HDMI cable issue

I have the SACD transport and the DSD DAC. I decided to buy a high-quality HDMI cable to connect the two using the I2S protocall. The cable came from Wyred4Sound.

No work! The DAC displays an error that there is no cable. I contact Wyred and they shipped out a replacement. Same behavior. My old HDMI cable works just fine.

Anybody else experienced this? I contacted PS and their pretty uninterested response is “don’t know what’s wrong”. Wyred tested both cables before they were shipped.

Wyred4Sound, by the way, is wonderful to work with. They shipped the 2nd cable without demanding the first be returned immediately. They paid for the return of both cables. And a full refund. Can’t complain about that kind of customer service.

Latest firmware on the PST?

Any chance that some of the connections in the Wyred4Sound cable aren’t connected or aren’t standard HDMI? PS Audio uses a few other lines than just the data lines.

1 Like

Yeah - the DAC died recently (note even a light!) - so it went back to PS ($125). I assumed the refreshed the FPGA load but checked anyway. Latest level.

Paul mentioned that the +5v is sometime not connected. I checked with Wyred and they said all lines are connected. They mentioned they have other customers with the same hardware and no problems. Not willing to spend $250 to return my units to PS - and go silent for three or four weeks. But I do appreciate your attention.

I noticed an earlier post by someone suggesting the HDMI sockets didn’t “grip” very well. I tried wiggling the connectors; no effect. And they seemed properly seated.

Are the DAC and the transport plugged into the same circuit? (e.g. the same outlet?)

1 Like

Short answer: no.

I have four 20 amp circuits for my sound system. The transport and DAC happen to be plugged into separate outlets/circuits.

Out of (engineer’s) curiosity, what difference would this make? Especially given that everything works ok with a different HDMI cable.

While I have your ear Ted, recently I had to ship my DAC back - it was dead. Not even a glow on the display. When it was returned I asked what was wrong. I go a vague answer about “the firmware”. I assumed, perhaps wrongly, that the FPGAs were used in the signal processing, not the power subsystem. What’s the story?

Thanks for your time Ted.

If the grounds of the two devices have too big of a voltage difference, that may keep any signals between them from being interpreted correctly. Different cables have different abilities to short out ground differences between their two ends. As an experiment try plugging both devices into the same outlet. If that works, perhaps consider a way to do that permanently or perhaps run a ground wire between the cases of the two devices (tho I’d want to know why the ground is more than a fraction of a volt different.

Do you keep an SD card in the DS? If it is the card that was used to upgrade the software in the DS then every time you boot you are upgrading the software in the DS and something may go wrong. If you need an SD card in the DS (for example to get covers on your screen when using the Bridge) you should make sure there are no software upgrade files on it.

There are (at least) four separate things that can get reprogrammed with new software. The Bridge, the XMOS used for the audio USB connection, the FPGA, and the display/control processor. The last is the one that controls all of the lighting including the blue power on button and the screen. Things can go awry if the control processor’s image gets corrupted somehow. One possible way is a power glitch while it’s writing some changes in settings to it’s PROM. (That should happen incredibly rarely.)


Unfortunately I returned the cables to Wyred4Sound. So further experimentation is not possible.

“It’s always grounds”. Univeral truth.

Curious - how many FPGAs of what size are in the DAC? I wrote software for writing and timing large FPGA arrays. Difficult combinatorial optimization problem.

I DO keep the SD card in the DAC. I’ll remove it.

Thanks again for your time Ted.

The DS (and DS Jr) use a Spartan 6 XC6SLX16-2FTG256C.


As it turns out, for the DS’s signal processing needs the bottleneck isn’t (one of) the obvious suspects, it’s the size of the RAM that can be used for filter coefficients. The Spartan 7’s used in the DS Mk II, etc. are quite an upgrade.

1 Like

The +5v line (pin 18) is not needed by the DS as stated by @tedsmith in another thread - he also stated that it will not usually cause a problem if it is connected. I have a cable from BlueJeans where they completely removed pin 18 for me (for a $15 upcharge). I did this to make sure no voltage could cross over and cause any additional noise (even though I could not detect any with an active pin 18 anyway). The cable (sans 18) works fine, so the lack of the +5v is likely not the issue.

If you have or know someone that has compatible i2s source (Matrix SPDIF 2, Douk U2 PRO, etc.), you can run one of those to the DS to check it’s i2s functionality. If it works with one of those, you know the issue is likely your transport (it is the Perfectwave Transport I assume and not some other brand of transport?).

Have you also tried another run of the mill HDMI cable - like grab the one for your TV - or simply tried the other i2s input?

My understanding is that everything in the system stayed constant besides the HDMI cable? After replacing it with the same cable and it still not working makes me think that the Wyred cable is doing something weird. Possibly similar to AQ eARC cable not being recommended for I2S use with us.

Yes. the only difference is a cable swap. My “old” cable (whose name I don’t have handy) works just fine. The Wyred4Sound cable did not. They kindly sent a second cable with also behaved badly.

The Wyred people say they have other customers using their HDMI cable to interconnect the same two pieces of gear.