DSD Sr. Failure

Hi - I have been trying to get a hold of PS Audio support for several days now with no response. My relatively new DSD Sr. has decided not to power on at all. Problem started with the Bridge II failing to show up in the configuration all of a sudden last weekend (I had last used it the previous day).

I turned off the DSD from the switch in the back and then unplugged the power cord. After waiting a few minutes, I plugged the unit back in, turned it on and … nothing. I’ve moved the unit to other sockets, tried other power cords and still no power. I have had no other power issues (no storms), the unit has been plugged into a Shunyata power distributor and no other component on that distributor has any issues.


I would start with checking for a blown fuse.


Sounds like the fuse

1 Like

i’m not being a brand fanboy but i’m surprised you haven’t gotten a response from PS Audio. Are you calling or emailing?

When i’ve called, for whatever reason, I’ve always gotten someone on the phone.

Sounds like a fuse failure.

The fuse is likely the culprit. The Lacquer Top has to be removed. Four dark screws on the bottom need to be removed. Only remove the four dark screws. If it’s fairly new it will have the PS Audio Supplied fuses. There are two fuse slots. One is enabled. I think that it’s the right fuse looking from the back of the device. the spare slot will have a back up fuse if I’m not mistaken. Swap the fuses. I would test them with a multi meter though.

Indeed, sounds like a combination of a fuse and bad timing. The RMAF is taking place this weekend, and there were a fair number of the Boulder staff there from Wednesday onward to help get the display room set up. So the home office has been running short-handed.

Sorry we haven’t gotten back to you earlier. Indeed we are at RMAF and I’ve hardly had a moment to see what’s going on here. I believe it’s a fuse as well. Watchdog is absolutely correct. There are 2 fuses on the power supply board and only one is in the circuit. If you are able to swap them, I’m almost certain the DAC will come right back on. Feel free to call and keep us posted with any questions at all.


Sorry about that! We closed up the company on Friday, hired a bus, and took everyone to the RMAF show. My apologies.

It certainly sounds like a fuse, and that’s the first thing I would check.

We will get back to you on Monday.

1 Like

Thank you all - I appreciate everyone’s feedback. Swapping the 2 fuses brought the power back to the DSD.

Now I am back to the original issue with my Bridge II failing to show up as an input option (in the Setup screen, it says no Bridge installed). I have tried reseating the card and re-installing the OS.

This is the second time this card failed - first within a week of purchasing it; I sent it into PS Audio for repair. It has worked consistently for about a year now until this past weekend when the same symptoms appeared.

Thank you - Michael

Good progress, but a frustrating new problem.

Have you looked carefully at the card, especially the pins? You can wipe the pins with Isopropyl Alcohol to see if that helps?

I would think that cleaning the contacts and reseating the card would be the next thing to try.

Any chance this is a network issue…?

Just for grins, try de-energizing the DAC and everything in the network signal chain and reboot everything starting with the router and finishing up with the DAC. (And, leave the SD card out of the DAC when restarting it.)

Worth a try, maybe…

Glad it’s up and running again. I would try resetting your network first if you haven’t already.
Also, did you try to update to the latest Bridge code recently?

I have re-seated the card a few different times and tried it on 3 different networks (resetting the entire infrastructure chain twice on 2 of the 3 to see if that would allow the DSD to see the installed card). I have not updated the Bridge code (the Bridge stopped working before the new code was released).

Thank you - Michael

That’s kind of weird. The fact that the Bridge isn’t showing up as an input usually means that its code is corrupt. Our service team is in and ready to trouble shoot your Bridge. Feel free to give them a call.