DAC Input Problem

Hello Fellow PS Audio People:

For some unknown reason, my Directstream Memory Player is reading disks but no data shows out on the Directstream DAC screen and there is no playthrough. Yes, I am using the I2S output and input and yes, the selector on the DAC is set to I2S. This is very troubling. I’ve unplugged the transport and the DAC and replugged them, all to no avail. Is it possible that the Memory Player firmware was screwed up by a recent brownout?

Did you use the i2s before the brownout? If no, try a different HDMI cable. I’ve had issues with directional cables (and active cables doesn’t seem to work at all).

Does everything work when you use a different output, such as coax?

Also, does the DAC indicate that it is connected? You could try the other I2S input on the DAC as well.

Duh! That did it. I tried the other I2S port and it works. I’m not sure that I like having a dead DAC port. I live in Canada and it’s going to be a hell of a job to get serviced.

1 Like

Thank you so much. I should have tried the other port before posting.

Do you have any deoxit cleaner? If so spray the end of the interconnect, not the port on the DAC. Than plug the cable in and out a few times to see if the issue is dirt related. This may get the bad port working again. Good luck