iFi Zen Stream with NAS setup

If anyone has an iFi Zen Stream, I could use some help. Mine just came. I hooked it up and got the white light at the left side (internet connectivity, fast). I got into the configuration page at http://ifi.local and went through the initial setup steps. All went well until I got to the last step, where I needed to connect to my music source.

My music is on a Synology NAS, which I can access from my Windows laptop as usual (so nothing wrong here).

In the Zen setup page, I can choose Settings / Sources and add a new drive. (See screen shot below.) But when I click Save, a red error message appears at the upper right which goes by so fast that I can’t read it; something about unable to connect or resolve address. I know that the IP address for the Synology is correct. I’ve entered my username and password for the Synology in the advanced options (not visible in the screen shot). I’m not sure what to put in the Path field. The Share Name in Windows is \\DS218-plus but that doesn’t work. I’ve tried a few things but nothing works. There are several folders with music on the Synology; is that part of the problem?

When I got my Zen Stream I tried to get this to work and also failed. I got around it with just using Roon.

Edit,

Another way to get around this is to click on “Media Servers” and your NAS server should show up:

Then you can either copy or remap what music you want to stream under your Synology UI.

1 Like

If you haven’t already look or ask here there are many power users plus two iFi employees that monitor the thread.

Reach out to this member/employee

Mr BubbaHyde

Mine is just set up as a streamer with a flash drive directly attached. No Roon here just Jplay for IOS.

Thank you for sharing this. I am not a Roon user. The Zen (intended as a replacement for the Bridge II) will have to go back if I can’t access the files on my NAS.

See my edit.

“Music Servers” is empty for me.

hmmm, what about this page under “sources”?

These should be all on just in case, and the switch in the back of the unit should be set to the auto postion.

Also, of course I assume you have already done this, the ifi and the Nas need to be on the same subnet.

Yes, all these are turned on, and I am using the AiO (all in one, I guess) setting for the switch on the back.

Thanks – I was not familiar with this forum. I found a thread here where a couple other people were having trouble connecting a NAS. Someone had success by specifying a new version of the cifs protocol (2.0 or 3.0 in place of 1.0) but that has not helped me.

If you have a windows machine, can your windows machine see the Nas as a media server?

My Nas just showed up if memory serves, I didn’t have to do anything special. Play around and see if you can get your wndows machine to see this:

Screenshot 2023-06-01 234646

Then, in theory you should be good to go.

Hope this helps.

No, I don’t see the NAS as a media streamer. But I never stream music from my Windows machine. I have MinimServer installed on the NAS. I get the following in Windows:

If I click on the IFI icon I get a folder with three subfolders, one for DS218 (my Synology), but the folder is empty – presumably because I have never been able to mount it as a drive.

last shot, under your NAS web UI, not surewhich version of DSM your NAS is using, SSDP should be checked:

Also if you haven’t done it already, update your iFi to the latest firmware won’t hurt.

Try here about a quarter of the way down the page

Just for fun/or for kicks, I followed the instructions on the head-fi link, it took me couple tries but I had gotten my music folder to mount and work with iFi’s latest firmware.

Here is what I put in into my iFi, the key is the Options field(no cap letters it’s case sensitive) need to be filled in my case:

Thanks again for your help. SSDP is enabled, as is the general Bonjour discovery (but not Time Machine, which is an Apple thing I guess). I checked and the iFi has the latest firmware. I tried both vers=2.0 and 3.0; no difference. My Synology is using DSM 7.1 with the most recent update.

Sorry to hear that, if the username and password is correct I’m out of ideas. :thinking:

Make sure the path is correct, did you try \\Music instead?

Well, I finally got it. It was a combination of three things.

  • To log in to my Synology from a browser, I have to add :5000 to the end of the address. IFi does not like that port number (I left it off).
  • I had to use vers=2.0
  • I suspected that the problem was with the path. I have several folders on my NAS with music and wasn’t sure to how to get them all to work. As an experiment I added ‘folk’ (no quotes) as a path.

I was finally able to mount the Synology. (I had tried these things and others in various combinations before, but this did it.) So I guess I would have to add each directory as a separate source with its own path. BUT at some point MinimServer showed up under Media Servers – I’m not sure what caused this to happen. Now I can use mconnect or the Linn app on my iPad to control things, which is what I wanted all along. When I’m feeling brave, in a day or two, I’ll change the switch on the back from AiO to DLNA and see what happens.

1 Like

Things have been working well with my Zen Stream, and it has been sounding very good indeed after some additional break in. I changed from AiO to DLNA mode.

Yesterday I added some DSD256 files to my music library (DSD64 has been playing fine). The new files appear as expected in my control point (Linn Kazoo) and I am able to add them to the play queue. But when I try to play one of the files, nothing happens; the control point stays stuck at 0:00. No light appears at the right side of the Zen – I think it should be red for DSD256. I take this to mean that the Zen is not sending anything out to the DAC. I am using the USB input on the Mk2.

Has anyone gotten DSD256 to work with the Zen?

Try taking the “:5000” out of the IP address.

1 Like