Issue with Snowmass 3.06 (and Windom), killing sound randomly on USB input

I found 3.06 to have more high frequency energy and detail, than 3.0, while running the DSD direct. Now that I’ve added the BHK pre, the sound is even more glorious across the entire frequency spectrum.

Thanks for the replies, one other thing, how the heck did my username become Christos?
I originally joined this forum as Soliver, yet I guess after the change several years ago to the new look, my email and password now signs me in as Christos, versus Soliver. If I was my brother whose middle name is Christopher, perhaps.
Sorry. I don’t post much, more of a lurker

I think this is a legacy forum issue. Others had whacky names appear a long time ago. @Elk will deal with it.

I changed you back to Soliver.

Sorry about that.

If you need anything, just let me know.

So this exact issue happened to me…
I was trying windom and switched back to snowmass 3.0.6, connected to innuos zenith via usb.
I could play optical…but no sound on usb.

2nd time this evening - the only fix that worked for was is a restart of the dac.
@jamesh - is this a known issue -any work arounds ?

Just so I’m clear, with Windom, the USB and optical is all working well. But when you rollback to 3.06, optical works well but USB will only work if you power cycle the DAC?

Rolling back to snowmass 3.0.6 listening to USB, the sound just dies. Switching to optical = no issues.
The only way to get the sound back is a power cycle.

Yes, I had same no sound from usb, at some point with Snowmass. Rolling back to Redcloud and new installation of SM with reboots and all interconnects disabled, solved the issue.

Thank you @Somppsa.
If i have this again - il give it a try :pray:

Very weird. If there were something critically wrong with 3.06 and USB, I hope I’d be aware of it.
Try out Somppsa’s suggestion, and let’s see if it helps.

I had the same problem with Snowmass.

I think you should be doing new firmware installation in any case now to get everything working correctly,since you clearly have a bug in your dac now.

I like the sound of snowmass better - so upgrading to windom doesnt work for me.

XFYI, Windom appears to behave just like Snowmass 3.06
Switched firmwares last night and after about one hour, suddenly my USB connection went dead. Immediately switched to XLR to continue listening, but still the only thing that brings back the USB connection is a complete DAC reboot. Tried again today, first try no sound from USB upon start-up, 2nd try USB sound lasted 30 seconds before it died.
I’ve ordered one of the new Curious Evolved Cables to try in place of my usual Sablon Audio USB, to see if that helps.
Yet to have this happen on any other firmware prior to 3.06, so something must of changed (well have only used 3.00, didn’t try any other Snowmass versions until 3.06)

I have a DSJ and just upgraded to Windom. I too have a curious evolved cable with an ISO Regen in between. Prior to this I had Snowmass 2.02.

My DAC will also randomly cut out. The Mac mini running Audirvana (Tidal) keeps playing but the DAC just stops “playing.” Only remedy is to use power switch to reboot DSJ.

Called PS Audio and they said:

  1. Turn DSJ off via power switch. Push and hold PS Audio logo in front and switch back on. Release PS Audio logo. (This does a hard reboot) - Problem still persisted
  2. Called back and then I was told to reboot MacMini

Still had issues so I reinstalled Snowmass, then upgraded again to Windom. Will let you know how I goes. Definitely annoying. If continues I will call PS Audio yet again.
As I finished typing this it happened again. DANG! :(:(:frowning:

Cuh-rap! :frowning_face: I was hoping this would be fixed.

Trying Windom - this happened after 4 hours of trying windom. Sound just stopped. Only solution was a power cycle.
@jamesh - can some one from PS pls look into this and tell us what the reason / fix might be.
Clearly something is going on.
And btw - i did try

  • powered down the dac
  • powered down the zenith
  • unplugged the cord on the dac
  • unplugged the xlrs
  • plugged the xlrs
  • plugged the power cord
  • powered on the zenith
  • powered on the dac

-----And yes it happened after that as well

Happened Again !!!

@Soliver - now that this has happened on Windom as well, maybe you can consider changing the title to include Windom as well… just a thought.

I have the exact same issue with Windom 401. USB goes silent after a few minutes and I have to reboot DS and/or my laptop. Works perfect with Snowmass. I wish there was an easy fix or patch for this?