Issue with Snowmass 3.06 (and Windom), killing sound randomly on USB input

So I have never really had a problem with any firmwares, after many years of ownership and all of the various firmwares, and my surrounding system has stayed pretty consistent.
But after downloading 3.06, and loading it up, my digital will just randomly die at weird intervals.
And to get the sound back the only thing that has worked is re-booting the entire DAC.
I have spent maybe 10-12 hours of listening to 3.06 and my sound has died about 8 times. Sometimes it has happened after a few minutes, another time it went for about 4 hours before doing it once.
My front end consists of a Bryston BDP-2 using a Sablon Audio USB cable.
In the past with other firmwares, I have had the Bryston lose sync, and I have had to hard unplug the Bryston PC, plug it back in then make sure its USB output is re-enabled. Annoying, but it has only happened like once every 2-3 months. So not a big deal.
But with this new firmware, the drops are way too frequent. And like I said the first time this new dropout occurred, I tried that same routine, but it had no effect. Again the only thing that worked was re-starting the DSD.

So far I have re-downloaded the 3.06 files, re-formatted and tried different SD cards, downgraded to old firmwares before re-uploading 3.06, etc.
I haven’t tried uploading firmware, turning off DAC, and popping out the SD card before turning it back on.

Any ideas what may be happening? So far I think I like 3.06 more than 3.00, thus I would like to solve this so I can reliably listen.

I haven’t heard this happening with anyone else. Any chance you can go back to 3.00 for a few days and let us know if it happens again? I don’t want to blame 3.06 too soon as I haven’t heard this happening with other people.

The USB on my DS seems to have up and quit functioning no sound. I am running 3.06, roon Core on a Small Green Computer sonictransport i5 to Ultrarendu. The Ultrarendu won’t recognize the Direct Stream over USB running diagnostic . The DS will play optical and Coax. Still trying to figure how to bring USB back. Have reloaded 3.06 no joy and rebooted everything else except network router. My first Direct Stream was DOA on optical port.

Hoping not going to have to return this one for USB. Going to reboot the router, swap out USB sources, USB cable, and try a different USB DAC. Have not tried firmware regression yet to 3.00.

Tired of troubleshooting with this PS DAC but loves the sound when they work.

Tired of troubleshooting already? Come on Mr V, you’ve only had two failures!

I did have an issue that sounds somewhat similar to yours.
My DS would just go into mute and stay stuck in mute and the volume control would not operate properly.
Ted had suggested that it was a power issue feeding the DS.
It took a while for me to prove his suggestion, I thought it was firmware related.
Here it turned out that the circuit feeding my P300 was at fault and the P300 can only make up so much.
So l had a low voltage feeding the DS which was causing the volume and mute to operate irrationally.

Yeah only two in six months and double DS burn in.

Interesting theory no power regeneration though I checked power cord at unit. I will try wall. After some DS reboots and 3.06 reloads with USB unplugged the ultrarendu communication over USB returned to the DS. However Roon will not play over USB still . Other streamers over optical and coax still work to DS. So power issue seems remote. .

The roon when you pick a song on an album it cycles through each songabout 3 seconds but no sound output. I am open to suggestions. This was original issue before DS stopped reporting.

Interesting diagnostic on said it unmuted the DAC. But seems other inputs would be muted too.

I loved the Ultrarendu USB sound into the DS until all went tits up.

Drop back to one of the earlier Snowmass versions and see if it clears up.

1 Like

Do you have another usb cable? Just make sure …

I got a resolution from Jesus over at Roon Support.

Founder of SONORE Computer Audio
Try this in order:

Remove the power cable from the Rendu and the DAC.
Connect the power cable to the DAC and power it on.
Connect the power cable to the Rendu.
Go to Apps / DAC Diagnostics and confirm the DAC is present.
Go to Roon / Settings / Audio and enable the Rendu.

Christos, please let us know if this works.

It worked for me.


Sorry for the late reply

I have been trying to resolve the problem for the last several weeks. But unfortunately nothing has worked, so I guess it is 3.00 for me.

I have downloaded the firmware 7 or so times, I have used a multitude of SD cards, and I have even used different SD card loaders.

Apparently this version affects only the USB input in some way different from others, I recently got back my Shunyata Anaconda XLR Cable, and when the USB dies, I can switch to the that for relief, but it doesn’t pass DSD, plus I had upgraded to Sablon USB because I felt it was slightly better than the XLR.

So after all these reboots, etc I have determined that my USB drops out after about 15 minutes on average, it’s been as long as 3 hours, and as short as 20 seconds.

And as mentioned, once it drops I can still switch to XLR for music, plus media player still shows music progressing along the timeline.

Very weird, I have had the DIrectstream since about 1 year after it’s release, so I have had it for at least one numerical firmware, and all of the named firmwares and never had this problem before.

I do find it curious that a firmware that fixes random Bridge issues, suddenly drops the volume to 25, where as most every other firmware leaves the volume at 100.

Disappointing as I still prefer 3.06 when I’m determined to listen to it and deal with the dropouts.

There is a setting in 3.06 that allows you to pick either fixed or variable volume for the DS.

That was a good idea for a new feature to add. I must have missed it in the release notes.

I had the USB drop out immediately after going from 3.00 to 3.06. A power cycling fixed it and from then on it was okay. I then tried a reload of Redcloud followed by a reinstall of 3.06. In that case the USB did not drop out did not occur right after the install, and has not dropped out since. I may have missed it @Soliver, but did you try going back to Redcloud or Torreys and then to 3.06?

I have used Yale as my old firmware to flash back to, not Torreys or RedCloud. It was just the first one I grabbed on a card, guess I could try and look for a more recent firmware.

So I tired the bump from RedCloud to Snowmass and no bueno.
Currently listening to XLR because USB died.

Sucks, perhaps it’s the USB cable but again it hasn’t done this on any other releases over the past 3 years.

This has forced me to listen to Yale and RedCloud again, I had a guy over returning my XLR cable to me after an extended loan, and he happened to arrive while I had Yale loaded. I upgraded to Snowmass and a summary of his response was “Hol* *hit”.

Just sad that I guess I have to keep 3.0 even though I prefer 3.06, less strident in the highs on my system.

Plan to post a listening comparison between the Directstream and some DCS DAC’s soon in a friends system.

Other annoying thing is that other than Torrey’s final, I’ve always preferred the original release,
Yet for some reason 3.06 is better, in my system.

Interesting . . . I rolled back from SMv3.0.6 to SMv3.0.0 in part because in my system SMv3.0.0 has the less-strident highs.

I hope your USB issue gets resolved.