Matrix X SPDIF 2 with Innous Zenith MKII

I received a Matrix X SPDIF 2 today. I’m powering it with a Small Green Computer Linear Power Supply set to 6V.

I have an Innous Zenith MKII streamer and a PS Audio Direct Stream Sr. DAC. The Zenith hosts Roon Core. The Zenith is connected to the Matrix via WW Platinum Starlight USB cable; the Matrix is connected to the DSD via a low budget (at the moment) HDMI cable to port IS2-1. The indicator on the DSD screen is green, so I assumed the DSD recognizes it’s connected to the Matrix.

Roon cannot find the DAC. I’ve rebooted the Zenith and DAC with the Matrix installed. Any suggestions or help would be appreciated.

Probably a dumb question, but does the Zenith support external USB audio devices?

Yes it does. It has two outputs. Ethernet and USB. I currently use both with the DSD. USB to play anything, including DSD128 songs; and Ethernet to Bridge II to play anything, but DSD128 songs because Bridge II only works with single-rate DSD (DSD64).

I purchased the Matrix in the hopes that I can eliminate a network switch, and get better SQ over HDMI.

Have you tried a different USB cable?

I’d look for a setting along the lines of “enable internal devices”.
I run Roon on Euphony server. Euphony provides a setting named Roon + Stylus, and the +Stylus part is what enables me to play through the Matrix. As you know, the Matrix is not a Roon Ready device. You have to use some sort of trick to get it to work. I have know experience or knowledge of Innous gear so I can’t tell you exactly what you need to do. Sorry.

My Zenith is Roon Ready and it hosts Roon Core. I will take a look at Zenith Settings. You never know :slight_smile:

The Zenith shows the Matrix as the DAC:

I have the very same gear you do and using the Matrix in the same manner. I can switch back and forth between I2s and Bridge (though not a fan of the Bridge sound comparatively speaking). Have you tried turning off Roon and using UPnP streamer on the Innuos to see if that works using iPeng or Mconnect on I2s? I recently had problems with the Roon core on my Innuos working properly and Had to have Innuos support log in to reinstall Roon. After reinstall it’s all working fine now.

I figured it out. After enabling the Matrix, I had to change Roon’s Latency setting to “Normal” and I was using Roon Core with LMS Lite. I changed back to just Roon and it now works. I’m going to play with those settings again tomorrow.

1 Like

Yeah, I should have asked about that setting. Roon core with squeezelite doesn’t work for me either. I have to use Roon core only or turn off Roon and go the other direction. I’m glad you got it figured out. I recently added an Etherregen to the mix and that seems to have helped open up the soundstage further and add a bit more clarity.

I’ve thought about adding an Etherregen even before the matrix. I may look into it again. I’ve got so many tweaks and upgrades now, it’s getting harder to sneak things into the house past my wife :slight_smile:

Hmm…it should work. Have you checked all Roon settings,there should be separate option to enable squeezelite. It is disabled as a standard.
I am sure someone can point you out where it is,if you cant find it.

It’s a shame you have to spend so much on cables and boxes to use usb because the Bridge doesn’t do higher rate DSD. One of the selling points of Innuos when I bought a Mk3 was the Ethernet output, which I use with a $10 BJ cable and no switching. Is there no other was of getting Ethernet into the DAC?

I’ve had my DSD for a little over a month now. In my system, USB sounds fine, but I think the Ethernet SQ is better. From everything I’ve read, HDMI is even better. Using the Matrix and HDMI, I can eliminate my switch and hopefully get better SQ.

Unfortunately, the MKII “Streamer” Ethernet port and Bridge II Ethernet port will go unused. But so be it.

1 Like

In my post, I was referring to the Zenith “Roon Core with Squeezelight Player (Experimental)” Music Server Integration option. To get the Matrix to play to the DSD, I had to set the Music Server Integration option back to “Roon.” I also changed the Latency option from “Low” to “Normal.” When I have time today, I’m going to set Latency back to Low to see what happens.

I’ve never used Roon’s Squeezelight option, although I may try it to create a backyard music zone. I still have a couple of unused Squeezeboxes and Raspberry PI’s configured to LMS laying around. LMS is the Swiss Army knife of media players and the SQ is great. Before I moved to Roon, I used LMS to synchronize my Squeezeboxes connected to receivers, Airplay speakers, and Chromecast Audio speakers throughout my house.

With Roon, I use Airplay and the Roon Ready Zenith and a Raspberry PI configured for RAAT, but of course Airplay and the Roon ready devices are in separate zones so I’ve lost “whole house stereo.” But with Roon’s music management capabilities, that’s a trade-off I can live with.

Hmm! I spent two long remote sessions with Innuos support over the past month getting Roon to work. I haven’t tried it again since the last fix not wanting anything to go wrong. Perhaps I’ll try it again.

Well I don´t suggest anyone to use Roon ,but reason why your Roon Squeezelite isn´t working is most likely because you have not enabled it in Roon settings. Nothing will go haywire if you just click it on ,and you should get it working.

Here is one link I found… just check it out

And from Innuos : Instructions to use the Internal Player with Roon

  1. Disclaimer - this is an experimental feature which may have occasional dropouts. It uses the Squeezebox integration within Roon which supports only audio up to 24bit/192 and DSD64. Quarantine and Import will be disabled as they require the internal LMS to be active and that would conflict with this feature on Roon.
  2. Go to Settings > Choose Server Integration
  3. Activate the Roon switch then select the option “Use Roon Core with Squeezelite Player (Experimental)”
  4. Click the Apply Changes button
  5. Launch the Roon App
  6. Go to Settings > Setup
  7. Activate the switch for “Enable Squeezebox Support”
  8. Go to Setting > Audio
  9. Disable any players shown under “Connected to Core”
  10. Enable the Squeezelite player under Squeezebox.

Glad you got it working. Squeezebox isn’t Roon, no point in using that setting unless you have an actual Squeezebox device on your network. In this case, it’s still odd given the Roon Server is directly connected to the Matrix.

vee, you are correct. When I first purchased my Zenith, I used LMS with squeezeboxes and squeezebox emulators. It worked fine.

I like to tinker. At some point, I’ll setup Roon Squeezelight just to see how it works. Having said that, there’s no way I’m going to use Squeezelite in place of Roon. I have a lifetime subscription so I’m sticking with it.

1 Like

I’ve been listening to my favorite jazz and old school R&B songs for most of the afternoon. I can honestly say the SQ with the Matrix is clearly better than USB from the Zenith or Ethernet from my switch.

I hear more details in the music with subtleties I faintly heard and tones I never heard before. The sound is also clearer. Now I’m going to look for a much better and warmer HDMI cable.