MControl MConnect app and premature end of stream?

I listen to Qobuz streaming audio on my DirectStream DAC using the android version of MControl’s MConnect app. When streaming a series of tunes in a playlist, the app often cuts off a large portion of the audio stream from a tune. If I play that tune by itself, no problem; the cutoff occurs only when there is more than one tune in the playlist.

This brings up two questions. First, has anyone else experienced this? And, second, is there a remedy?


I just got an Ifi zen stream a week ago. I installed mconnectHD and loaded Qobuz. I was one of the people that fumbled the ifi setup. (Took me 2 days). Soooo, Yes I experience the occasional drop outs also. I’m not totally sure when it occurs but seems to me that it drops out more often during long songs, also more often when the recording is live. I don’t have a clue if this happens due to the mconnectHD app, or the Qobuz or the zen stream. I had fiber optic network installed a few days before I got the zen stream. I’ve had the problem occur using cable or Wi-Fi. The signal strength is great either way. It also doesn’t matter what resolution the song is playing. 16/44 - 24/192. I hope someone can help us both.

I’m a streaming newbie. Just started my first Qobuz subscription and it’s a nice addition to listening to discs and downloaded files. I have the DS1 with Bridge II on one system and an Oppo UDP-205 on the other functioning as the renderers. I first tried MConnect & had the issue you describe maybe twice. Also MConnect couldn’t recognize my Oppo for some reason, but worked with the Bridge II. So then I picked up BubbleUPnP (wishing to do this as cheaply as possible while still in experimental mode).

BubbleUPnP recognized both renderers, and has been less glitchy as well. I have had it stop during a playlist, but only between tracks, not during. I busted out the big bucks & upgraded to the licensed BubbleUPnP for the one time fee of $5. So I’d suggest trying BubbleUPnP, it’s free for a try – free version allows only 16 tracks in a playlist, and a few other restrictions, but now I’m a happy streamer camper!

1 Like

There are various versions of the Converse Digital software: Mconnect control and Mconnect player, which come in HD, regular and lite versions. One of these (I believe it’s Mconnect control, but I can never keep them all straight; I’m sure someone will remind me if I’m wrong) is specifically designed to work with Converse hardware. They were involved in the development of the Bridge, which may explain why you had success with that hardware but not with the Oppo.

1 Like

I can confirm MConnect Control is the app for the Bridge II which is made by ConversDigital. The Control apps are free. The HD version is optimized for the iPad and the regular version is optimized for iPhone. It works well with Spotify and Tidal since the app transfers you to the Spotify or Tidal app. For Qobuz it works within the MConnect app which I find a poor interface. It can also work with JRiver, but the JRemote app is much better for that. The paid MConnect apps are for non-ConversDigital hardware.

1 Like

I’ve had a similar problem with my AirLens connected with I2S to my DS DAC Mk 1. I don’t use playlists. This occurs playing the tracks in a selected album in Qobuz. Tapping Previous to choose the track again always results in the entire track playing successfully.
This issue has never occurred with the Bridge II in the DS DAC Mk 1.