P10 can't connect to my router


#1

Hi,
I recently bought a P10, registered it, [tap & hold screen during init] updated the firmware to latest 0.00.41 (see attachment) and restored defaults.

20170530_214803-1.jpg

Then wired the P10 to my TP-Link C8 router and just in case rebooted a couple of times router & P10 in different orders.

Still, my router couldn’t see/give a new IP address to the P10.

Of course, my router has DHCP enabled and I can see the P10 Ethernet socket’s green/yellow LEDs blinking (as my router’s LED), meaning there is a handshaking going on…but no luck, the P10 ‘internet’ little icon is still ‘red’

If I go to SETUP, LEFT ARROW I can see the default LAN configuration:

20170530_214739-1.jpg

The problem is that the the P10 is reading or getting a wrong Gateway (192.168.1.1), DNS (192.168.1.100) and IP (192.168.1.222).

My router’s default gateway is 192.168.0.1 with an IP address pool from 192.168.0.100~199. My router can’t give a new IP or assign a gateway/DNS in the range 192.168.1.XXX

All my devices at home (some with static IP, some with dynamic IP) have an assigned IP that ends in 0.XXX and gateway 192.168.0.1

I don’t know what do and reading http://www.psaudio.com/ps_how/how-to-connect-a-power-plant-to-the-internet/ didn’t help me either. The “HOW-TO” is correct, DHCP should work (at least it always works for me :slight_smile: and should be as simple as wiring the P10 to the router.

Can somebody help?

Thanks in advance,

Javier


#2

You have DHCP enabled on your P10 and it is not getting an IP address from your router. 192.168.1.222 is the default IP address when the P10 can’t get DHCP. You have 2 choices, choice 1, find out why the P10 is not getting and IP address via DHCP, choice 2, set the P10 to a static IP address.

Dennis


#3
Dennis Kerrisk said

You have DHCP enabled on your P10 and it is not getting an IP address from your router. 192.168.1.222 is the default IP address when the P10 can’t get DHCP. You have 2 choices, choice 1, find out why the P10 is not getting and IP address via DHCP, choice 2, set the P10 to a static IP address.

Dennis

Hi Dennis, thanks for your prompt answer.

I believe for choice (2) I need choice (1), meaning the P10 has to already be connected to the LAN in order to access the P10 and change to static IP. Don’t know how to do it (or if it’s possible) from the P10’s control panel (display).

Anyway, you’re correct, it has to be something between my router and the P10. Other devices at home have no problem, but it must be some router configuration that is eluding me. I’ll keep debugging the router.

Thanks for your time,

Javier


#4

Are your other devices running DHCP or static IP addresses? If they are all static IP addresses, make sure you have a DHCP server running.

You can always hook your P10 to your computer with a cross-over cable, Change your computer to an IP in range of the P10, then connect to the P10 and set it to a static IP address. Then put it all back.

Dennis


#5

Y

Dennis Kerrisk said

Are your other devices running DHCP or static IP addresses? If they are all static IP addresses, make sure you have a DHCP server running.

You can always hook your P10 to your computer with a cross-over cable, Change your computer to an IP in range of the P10, then connect to the P10 and set it to a static IP address. Then put it all back.

Dennis


yes, as I wrote in my original post I have a combination of static/dynamic IPs, DHCP’s always enabled at home, etc.

Now is working, rebooted everything and left the P10 power-on overnight and next day, voila, it had an IP assigned. Probably the router was lazy :slight_smile: (I really don’t know what happened)…

BTW, your idea of connecting the P10 (or any device) to my PC with a cross-over cable is very good! I’ll keep it in mind next time I have a similar problem.

Thanks!

Javier