Powerplant not getting an IP address

Hi everyone.

It has been exactly 2 years since I received my Powerplant P15 and since then it has been connected to my LAN. I was happy to use it, but after a few days away from home I came back and now I can’t even connect to it as it is not getting an IP address from my LAN DHCP server as before.
The connection lights behind it work properly, with the green light steady on and the yellow light flashing now and then.
Does anybody here knows what is happening and how to fix it? Is there a way to set a static IP address?

You can disable DHCP and enter a static address if you would like just log into your PowerPlant and click on “Network.”

To get started go to http://powerplay.psaudio.com to control your PowerPlant.

1 Like

Sorry, Elk, but there’s no way to log into the Powerplant since it gets no IP address. And as far as I know there’s no way to disable DHCP from its front screen.

Did you go to http://powerplay.psaudio.com?

This is where you get access to setting an address, etc., naming zones and other features.

I think you may need to register your unit with PS Audio first, but it has been too long for me to remember. I do recall it is very easy however.

I think his P15 lost internet connectivity altogether, so he’s unable to access it on the network.
I would start by making sure I have the latest firmware, then restart the DHCP server be it a router or otherwise.
If that does not work, I would try resetting the the P15, and bear in mind there were reports the plug shapes on the display could change to US instead of EU, but I would not worry about that.
If this does not work, I would reinstall the firmware.
If firmware isn’t good, I would contact the dealer.

1 Like


Everything done but the problem remains.

Did it but … nope.

Yes, it seems to be my next step. Thanks for your time, anyway,

Thank you @Serhan . You are wonderfully helpful.

1 Like

Hope the connectivity thing gets resolved quickly, and regeneration is still working as usual.

Thank you for the encouragement. Yes it feels good to help, though at times it feels like being nosy LOL.

1 Like

Sometimes one needs to be a bit nosy to obtain a better sense of what is going on.

1 Like

I assume you tried rebooting the network as well?

1 Like

Hi @jamesh. I did all the possible things at my fingertips like changing the switch port and the Ethernet cables even if they don’t appear to be defective.

Are you connecting through a router? All my networked audio gear in my system is. When I’ve encountered this issue in the past, not with a P15 but with networked Bryston digital components, I’ve hard restarted everything with a power cycle. That means my router, all switches, the lot. When you repower network discovery reinitializes. That has fixed the issue for me when nothing else seems to work.

After hours on searching for the problem I found that it worked when connected directly to one of the router’s ports. Since a simple reboot of the switch did not solve the problem, I did a factory reset. This happily solved the problem.

Thank you all for the support.


Great news!

Excellent! Enjoy the rest of the weekend.

Nice, glad to know it was a simple fix!

1 Like