P10 & PowerPlay access

Hi all. Just a quick question. I have a P10 which I purchased new in October, 2016. I have recently been able to run ethernet cable to the P10 and wanted to access the PowerPlay function through the “My Products” section of my profile. I registered my product way back in 2016 and was informed then that to access PowerPLay I had to be wired up! I am now but the product is greyed out and it doesn;t seem to recognise my product wired up. Any advice much appreciated.
All the best

Welcome rjb301. From my PS menu in the products page, , did you go straight to power play?
Does the message rad like this:
“It looks like you don’t have any PowerPlay-enabled products registered, or your devices aren’t connected to the internet.”

Thanks for the prompt reply! Yes. It says this:
# PowerPlay

It looks like you don’t have any PowerPlay-enabled products registered, or your devices aren’t connected to the internet.

You can register PS Audio products you have purchased here.

I have registered the product though. Am I missing a step?
thanks again

When you connected the LAN cable, was the device switched off from the rocker switch? Most devices need a restart to acquire an IP address and get recognized by the router. Only then will it connect to the internet.


Maybe leave it plugged in and wait overnight?

No, it should acquire an IP address and connect right away. If you have a computer, are you able to see the device on your local LAN? Can you access your local P10 screen?

Thanks mate! Yes. I am getting the IP address on the P10 and it is saying it is connected on the screen of the P10 so might wait. Appreciate your response. Hope all is well and safe in your neck of the woods.
Sydney, Australia.

Hope you’re safe too. Sorry I could not do anything for you.

I had the same issue and it was because I’d entered the serial # wrongly. On my P10s the second character of the last 8 alphanumerics is an ‘I’ - but it’s so small I’d entered a ‘1’ instead - maybe you’ve entered a zero instead of an ‘O’.

I could go to my browser and enter the IP address, i.e. http://xxx.xxx.x.xxx and see the P10 so I knew PowerPlay ought to have seen it if I’d entered the serial # correctly… HTH

1 Like

I just looked up your registration and all seems good. I just sent a note to one of our web guys. He should be able to fix it soon. I’ll keep you posted.


We just found the bug and you should be all set!

1 Like

Hi @jamesh !! Thank you. I can access this now. And also happy it was a bug and not a lack of understanding from me!! One last thing. When I go to “My Products” my P10 is greyed out (??) saying the warranty has expired. Is that normal?
Thanks again for your (prompt) reply and solution.

Always a pleasure. The greyed out appearance is just indicating that it’s no longer under warranty.

I’m in a similar situation. I accessed my Powerplay for years without issue, until the web hosting changed. Now I am seeing the same error as above. I updated my product registration and can access the unit on my local network. Appreciate any help you might have.


I see you only have a few IPC 9000s registered. Are these what you’re trying to look up?

It’s actually the same IPC. The entry with the serial number all as one string is the original entry that worked for years, and yesterday I added the same entry with the proper format with the dashes.

OK, that makes sense. I do apologize, but sadly the new PoweraPlay site doesn’t support the IPC 9000. My understanding is that it only supports all of the PerfectWave regenerators along with the current line up.