P10 screen comes on by itself, remote not responsive


#1

My P10 has recently started to ‘switch on’ the screen by itself, which I normally leave off to prolong the life of the screen.

The remote is unresponsive and won’t switch the screen off.
(I ‘jiggled’ the batteries to ensure they were working ok).

The screen eventually switches off again by itself.

More of an annoyance than a real issue, currently.


#2

The same thing has happened twice on my recently purchased p20. I had to switch the main power button off to switch off the screen. Hmmmmm…


#3

winston007,
Have you upgraded your P20 to 1.19 software?
If not, that should solve your problem.


#4

go to the setup screen and look at the "version’. Hopefully it doesn’t say “Hall 9000”.


#5

When I go to the resource section, there appears to be no download for the P20. Maybe it’s me.


#6

Really? Are you going here? https://www.psaudio.com/support/downloads/

It’s the very last folder.


#7

Funny how my P10 thread has turned into a P20 thread.


#8

The thread upgraded itself. Pretty neat.


#9

Not really. The purpose of the thread was to seek help and advice about my P10, not go off at a tangent to a different product


#10

I fully understand, and it is one of my pet peeves. However, in the past, I have tried to keep threads on topic and have moved new topics to their own threads only to be met with deafening howls of protest and recriminations (from some of the PM’s I received one would think I beheaded a beloved family pet).

For what ever reason, this group greatly prefers to randomly meander. It can be particularly frustrating to new members and even more so for those who find the site looking for a solution to a problem.

In this case, the discussion of P20 exhibiting exactly the same issue seems on-topic in any event.

As to your problem, are you running the latest firmware on your P10?


#11

Elk, no worries.
Pretty sure I’m on P41 firmware version.
I had all sorts of trouble with my screen about a year ago and re-installed the firmware and it cleared all the issues.
Tried running through the setup and scope option to see if it would show me the firmware version but it doesn’t.
Is there an easy way to check what the version is?


#12

Now I feel bad that I jumped the shark by posting in the wrong area. Sorry.