P20 stays at Initializing screen. Need some help

The P20 gets stuck at Initializing screen.

It’s a two months old shipped directly from Boulder, CO.
It can be turned on before when received, left sitting unused for 1+ month.
Now when turning it on, it gets stuck at Initializing.

I have not checked its running version. Since it came in like end of JAN 2020, I thought it should have newer version.

Any suggestion I can reset this unit?

Darn! Sorry to hear about the problems you’re having with that P20.

Want to try a couple things with me real quick and see if we can find out what’s up?

Email me - tjt@psaudio.com


1 Like

Sharing some update…
I’ve tried to reseat the daughter card as instructed and secure some computer cables. Problem remains.
Strangely, I turned off/unplug power and do the following:
Have tried to insert the SD card and unplug few times, it starts running.
And at random, it had reboot continuously couple times.
Somehow by inserting the SD card and unplug, lightly pushing the network socket (Do such when power is off and unplug) triggers the different outcome of Working-Boot-up/Continuous-Reboot/Freeze-On-Initializing result.
Maybe something to do with the SD-Network board at the back.

Have anyone experienced the continuous-reboot (on its own) like that?
Even it boots up and initialize screen go away into dark screen, going into Ready state. I did not have chance to push the front power button yet, it goes into Initializing stage again after few seconds, repeatedly.

Weird, I’ve not heard of anything quite like this. Maybe some weird I/O board interfering if pressing on it makes some kind of change. Have you been able to catch our tech support guys on the phone?

Hello James,
Thanks for checking with me. TJ has email me something.
I have tried to install firmware from TJ’s attachment.
–> half-black-screen on initializing; Complete power-cycle and reinstall itself; Then freeze after that, with half-black-screen.

And then tried official 1.25 download.
–> Installed and show full blue-initializing after self reboot (no reinstall like last time), it then freezes at blue-initializing.
power off and unplug SD card, power back on, stays at blue-initializing.

I’ve email videos of both to TJ if you are interested to check out.
Thanks very much!!

The above, I mean, after it finished the first round of firmware installation (square button flashing for few minutes).
Then → Boot up and showing “half-black-screen” and to into standby mode (black screen)… after 30 second, it suddenly like “power-cycle” on its own and reinstall again (flashing). In between that I have not try to touch the unit at all.

Very funky. Because the different version of code had a different outcome, it might just be code related. Hard to tell for sure though. I’m sure if TJ is available today, so do you mind shooting his manager Mark an email. marks@psaudio.com