P20 stuck on initialization. Help needed

unfortunately trying to update the firmware on my P20, it is is not working anymore. It is stuck on initializing.
I downloaded the last update
I have used the 4gb SD card from ps audio
the unit was off when inserted the sd card.
i basically followed all the instructions

The card may be corrupt. You can try reformat and then load files. Otherwise PSAudio probably has a force load version.

Thanks a lot for your answer.
I have formatted the card ( the one provided by psaudio) twice and reloaded with no success, it keeps blinking blue and does not start…

Have you pulled power for a few minutes, then retried?

yes…also disconnected from the outlet.

I’m responding to your email sent to me now - I suspect forceload may do the trick, so let’s give it a shot.


I think TJ’s right. Much more common on the DS senior and Jr. But force load pretty much always fixes it.

Hi everyone,
First of all sorry for my bad American accent😂,am french!
I have just uploaded my P20 with the latest rev,and I encountered the same trick,my p20 goes to the end of the initializing process then shuts down,no way to get it working after that.first I made a mistake,filling the compressed files from the revision,then after realizing my mistake I did it properly.that should be the reason why…
Do you have any way to solve this problem gentlemen?

It might just be going into standby. Does pressing the logo button wake it back up?

I just got the p20 back from PSaudio, I will check later once installed in my rack.
I Imagine something went wrong during the upload, so I sent it back in Boulder…
their customer service is five stars so no worries

Hi Jamesh
Thanks for your help.No,pushing on the logo button does’nt wake it up.I went to a computer office they checked my sdcard and told me I did the right way with the rev download.When I switch on the rear master switch it lights up on the initializing screen,then shuts down.There is nothing I can do to get it back to life,pushing the front button even for a long time wont’ do anything.

All was working fine before you tried updating the firmware?

Yes,the only thing was there was no curve on the oscilloscopes screens,not so important for me but I wanted to perform the revision believing it would maybe solve this inconvenient…

I’m going to email you some files. Let me know if these do the trick.

Thank you very much Jamesh very kind of you!I will keep you advised.

It doesn’t work James,the files you sent were the ones than the ones I used at first,I retried with the latest,the p20 reacts precisely the same way.

I forgot something,before I tried to perform the revision of the p20,I told you that there was no curve on the oscilloscope graphs.The 4 gauges on the main screen didn’t work either,the needles were always stuck on 0.Permanent 0 output wattage,0 input and output distorsion…It didn’t afraid me as I could use the p20 this way,intending to deal with that later,maybe it could help you to know that…

Thank you for advising me,happy you get your p20 back working properly.James is helping me,we’ll find a solution.Hope I won’t have to ship it from France to boulder.Enjoy your P20

The files are a little different than the ones you can get from the website. The fact that you weren’t seeing any measurements at all is making me think this is not a code thing. It sounds like one of the cases where the oscillator card came loose in shipping. Do you mind shooting our service guys an email. service@psaudio.com They’ll be able to get you going in no time.

Yes of course James,thank you for helping me I appreciate,I’m gonna mail them right away.Have a good one

1 Like