P5 shutdown


My P5 suddenly shut off while listening to music. I tried to unplug all connecting components and press the power button at the back. The initialising screen stay for a few seconds and then turn black, the fan is spinning but turned off after a few more seconds. I have tried to press the reset button and examine the fuse. The fuse seems ok.

The issue is similar to Perfect Wave Power Plant 5 switches itself off reported earlier.

My P5 has been running perfect for 7 years after a service. It is 220 V unit.

Would this require a big repair?

I had a similar issue with a Stellar P3 regenerator.

I was about to send it to the Mothership for a going over but contacted PSA customer services first via e-mail.

They recommended that I turn the unit off, disconnect the unit from a power source and leave it be for 24 hours. Apparently, some gremlins can creep into the machinery from time to time and mess with the fault settings - resulting in an inability to stay powered up.

In my case, the electrical hiatus did the trick; and the unit has performed flawlessly for more than a month since the “reset”.

Might be worth a try with your P5 before contacting PSA…

Good luck to you.



Welcome to the forum.


Happy cake day scotte1!

1 Like

Thanks Scotte,

I did left the unit power off overnight twice. I also tried to press the front left blue logo while press the back start up button as reported from another thread. But the same results.
I am quite happy with P5 and it been running for over 10 years and required one service in between from the AD.



Good luck.

it is interesting, after 3 days left power off, I tried to power it again, the initialising screen goes off after a few second. Then I switched off and on again and pressing the front blue stand by logo on the left, this time it powers up. Then I switched off again and power up, this time after initialising, the screen goes to the Home Screen.
Actually I am considering to send it to repair tomorrow. Not sure if there is still something wrong inside, eg bad caps.

Sounds a little weird but the fact that you woke it up with the standby button makes me think it might be ok. The logo button might not have been engaging the way it needed? You could try the on/off button on the remote to test this theory. If all seems ok, I’d try to plug some gear into it to see if the outlets in the back are functioning as expected.

1 Like