Perfect Wave MK 2 - Not recognized via USB

Hi all,

I’m currently trying to help my father in law with his Perfect Wave MK2.

The DAC is working fine if he uses it with any connection other than USB.
If I connect it via USB neither his Windows 10 Laptop recognizes DAC nor a freshly setup raspberry Pi with Volumio installed.

So basically two problems:

  1. DAC not recognized on Windows
    It has been recognized before and stopped at some point. Reinstalling Drivers, Clean install, new Drivers, etc. nothing helped.
    Anyone have any other ideas than the official troubleshooting to get the DAC Working again on Windows?

  2. DAC not recognized on Raspberry Pi - Volumio
    I tried to circumvent the Windows Problem with setting up a raspberry pi, but also here the DAC doesn’t show. As far as I know this DAC has drivers for MAC & Linux preinstalled.
    I’ve checked the config Files for ALSA, but as far as I can tell there is not a problem.

Does anyone have any ideas/experience with setting this up and can help me troubleshoot the problem?

I would check the length of the USB cable and make sure it’s 2.0 certified, this is the most common problem we run into. Also, Did you try installing the Windows driver that you can find here? Under drivers

Thank you for the reply.

I’ve played around a bit more. And it just got more confusing.

  • Cable works and is certified.
  • Current update is installed. Same with Drivers on Windows.

Now to the irritating part:
If I run the update on the DAC again two things happen:

  1. It will run indifinitely unless I manually stop it. Tried it to have it run till the end, and stopped after ~ 24 hours. I can also stop it after 30 minutes and same effect.
  2. Windows is recognizing the device after updating, but only until the next restart of the DAC.

So basically I can get the DAC recognized after running the update, but only until I restart the device.

Is there any possibility of restoring the DAC back to factory setting? Or any other ideas why this could be happening?

How long is the cable you’re using? No, there isn’t really a “factory reset” for the DAC. Powering it down with the rear switch is as close as you can get.

Just checked and the cable used is a 1,5m Analysis Plus Purple Plus USB cable. In the past it worked all the time, so I also tried it with multiple different cables, but always with the same result.

No factory reset is unfortunate, I was hoping maybe this could help. Shutdown with restart is happening basically everytime, because the whole setup is running on a different circuit.

Do you have a different computer that you can try?