Powe plant 20 won’t start

Hi I just received a used mint P20. I plug it in, switch it on in the back, the PS Audio logo button lights up and…. Nothing. I replaced the fuse with an extra one in the plastic bag. The manual says that once you switch on, after it boots the front panel should display stuff. I get nothing. The 15 and 20A buttons in the back are released I’ve hit the blue standby button a few times in case it was on standby… nothing.

Any ideas?

Have you tried to press the dim button on the P20 remote to see if the screen comes on?

Make sure the blue standby front panel button isn’t sticking. Sometimes in shipment the buttons get stuck. With the unit’s rear power switch off, press in and out the front panel button and make sure it’s not sticking. Then try again.

BTW, it’s not just that the p20 screen is off, the unit is also not powering any components. The standby button is on. It clicks after a few seconds when switching on the power in the back. So it’s doing something.

It was being used in 20A mode. I’m using 15A. The guy forgot to do a factory reset. Could that be a cause? Is there a way to do a factory reset without the screen working?

Paul, pressing the blue standby button whether the unit is on or off doesn’t make any difference. It clicks in and out, so I don’t think it’s stuck.

Pressing the remote’s DIM button doesn’t seem to do anything. Remote is working— the light on the remote flickers.

I used my multimeter to check the fuse. The fuse is fine.

The RESET buttons in the back seem to be loose when you press them, so that’s good I believe.

It’s still under warranty and the guy who sold it swears it was working right before he packed it. What else could it be?

BTW an almost exact thing happened with a p15 a few weeks ago, except there the standby button wasn’t even coming on. I sent it back. How can these things be so sensitive to shipping? I have PSA DAC and PW SACD transport also and they haven’t given any trouble.

This is unfortunate but does happen. I just sold my Cary SLP-05 pre-amp on audiogon. The buyer said he has to press the input selector to engage the left channel. It worked perfectly for me. He’s taking it to Cary (he coincidently lives close) and we’re going to split the repair fee. What are ya gonna do (said in an exaggerated Chicago southside accent)?

If pushing the standby button doesn’t wake it up then something may have happened during shipping. If the fuse were bad, there wouldn’t be any life at all, no relay clicks nor front logo button turning on. If the SD card is in, I’d try taking that out. Maybe there’s force code in there for some reason and it’s trying to update?

No SD card. I guess I’m stuck.

I didn’t think that would change anything but worth a shot at least. Reach out to our team on Tuesday and they’ll have some ideas for you. It’s still under warranty so worst case, it needs to come back to the mothership for a few days.

Is it possible it’s just the ribbon cable needs pushing fully back on?

Unplug all things from the unit. Triggers, cords, etc. Unplug, and reboot.

My Stellar Gain Cell DAC had a similar malfunction including the power lamp staying on. It wasn’t until I removed everything that was attached, did I get a successful reboot.

I have found that to be good advice with any component.

1 Like

@chris5 can you tell me how to reattach the ribbon cable? Is there a picture somewhere? And if I open it, will it void the warranty? Thanks

If you look at “No Power with newly purchased P20” there are pictures. I can’t comment on voiding guarantee but it may or may not be a relevant thread

If you call our service guys today, they may be able to walk you through it. Based off what’s happening with it, they may be able to determine whether it’s something simple like a ribbon cable or more severe.

Yeah talked to them. No loose ribbon cable etc. Its currently somewhere in a UPS truck between my house in Santa Fe and Boulder.

You may be interested to know that it was not something simple. Don’t know how shipment caused this to happen. Maybe coincidence. Here’s from PSA:

“So it looks like they were able to replace the LCD and the LCD board inside the unit to solve the issues you were facing and it passed all our AP tests as well, up and running smoothly.”

Anyway, really impressed with the fact that they got it on Monday, and they shipped it out today (Wednesday)!

Wow. This is why this is my third PSA component (the others being DS DAC and PST)

1 Like

Thanks Paul. You run a great organization. Having worked in corporate America for 30 years as a computer scientist I know that the culture comes from the top—for good and bad.

In this case, great!

1 Like

Hmm, kind of weird something like this would happen in shipping. Who knows though. Great to hear the team is getting it back out to you so quickly!!