Power Plant Premier has high distortion and fans not working

Hi to all.

My Power Plant Premier shows a strange behaviour since yesterday.

Usually when the Premier is plugged in the power socket the fans are working for some seconds. When switched on the output distortion shows values around 0.8 percent.

Now the fans of Premier don’t com up when plugged in the power socket. After switching on the device, the input distortion shows 3.0 percent and the output shows even higher values at around 3.5 percent.

Also sometimes the device doesn’t come up. A single “-” is shown in the display an nothing more happens…

Has anyone an idea if this can be fixed? Or is the device broken?

Regards, Dirk.

Welcome, Dirk!

I suggest giving PS Audio service a call or contacting them via email.

Welcome Dirk! This sounds like premier’s regen may have gone. One of the most telling details is that the distortion out is higher than distortion in.

We are still able to repair these guys but based on their age, I really try and recommend against that option. Upgrading to a new regenerator is going to be the best option. Get in touch with your local distributor and they should be able to give you good pricing on a new one if you trade that Premier in.

Hi James.

Sounds not so good…

I’m not quite sure if the German distributor is able to repair such a device. I will try to get in touch with my local dealer.

Is the trade in for older devices still valid for foreign countries like Germany?

Thanks in advance,
Dirk.

I can’t promise your dealer will accept it as trade, but I’m almost certain Jurgen with HiFi 2die4 will be able to offer some better pricing. You can get in touch with him directly via email with hifi2die4@gmx.de

Thanks, I will try that :+1:

Hi James.

I got in touch with the German dealer. They suggested to replace the unit with a new model. They also made an offer to replace the electronic boards. But the price was high. So for me both options are not the way to go in these times.

From what I can say, the regenerator part does not look like to be broken. The green LED on one of the driver boards is continuously on in times when the Power Plant is working properly. There are times when the device is running several days. Then (for no obvious reasons) the relays begin to click in short succession. For me the problem looks more like problem in the control circuit. Also the device is able to drive an electrical heater with 2000 Watts without any problems.

In most cases (when the device is not working properly) the relays and the control logic simply does not connect the regenerator output to the device output and the relays are switching between regenerator and the the plain voltage. When switched on, several tries are needed to get into a stable function. This also makes me think that the control board might be the problem, and not the regenerators power stage.

It would be very helpful to track down the problem if you are able to provide an electrical drawing or at least a service manual with voltage values and waveforms to be expected at given measuring points. I have a master of electronics, so I think that will have a chance to trace down the problem with this kind of information. Any other ideas are appreciated…

Thanks in advance,
Dirk.

Thanks for letting me know Dirk. I just emailed you some documents that will be very helpful.

2 Likes

Many thanks for your quick response, James!
I will have a look into the documents and I hopefully will find the reason for the strange behavior of the device.

1 Like

Please let us know what you are able to determine.

Good luck!

For some reason the device worked without any dropouts in the last week(s). Good for me, but bad to track down the reason for the dropouts.

Usually electronics do not heal itself :wink:
So I think there must be a reason in the power distribution network that lasted for some days. During this period of time I saw the very high distortion on the input voltage from 3.5 to 4.6 percent and the Power Plant was not working properly. Maybe this caused the strange behavior of the device.

I will see if any problems will happen again and then I will start to investigate the (real) reason with the help of the document I got from James. I will keep you informed…

So stay healthy!
Dirk.

1 Like

Hi to all.

The problem happened again in the last days in short succession. So I was able to track down the problem the time when it happens.

Looks like the 5 Volt power rail has a problem. I attached a screenshot of my scope (TP12). You can see huge dropouts at around 1 Volt:

In the schematic I found that a 47 uF capacitor is smoothing the 5 Volts. Maybe the capacitor has dried out over time. Or maybe the capacity is at the edge of what is needed, so a small change in capacity causes the 5 Volt to get unstable. The 5 Volt power rail is responsible for the internal control logic. So the problem fits to the strange behaviour of the device. To fix the problem I placed a 100 uF capacitor in parallel to the existing 47 uF capacitor.

I also attached an excerpt of the schematics. Maybe this is helpful for other people…

Thanks again to James and the rest of the PS Audio folks for getting access to the schematics. This is what many High-End manufacturers wouldn’t do!

1 Like

Well done troubleshooting. Wish I had the schematic for the P3.
It’s a little strange that adding another cap to C5 fixed the issue. It’s not uncommon for the vreg (U6) to fail. C5, unless shorted, shouldn’t result in vreg dropping voltage below 5V. Voltage at C5 (and vreg pin 1) should be higher than vreg rated output (pin 3, perhaps at least 6V+). Probably worth checking pin 1 voltage never goes too low. If it does, worth checking TP12 is 5V. If not, then need to unload 5V rail and check then. There could be a short or vreg has failed. Some of them have thermal shutdown embedded…

@nordic:
Hmm, I think you’re not quite right.
The screenshot above already shows the 5 Volt power rail at TP12. What you see is that the 5 Volts drops down to 4 Volt in every half wave of he AC power. D5 and D6 convert the AC power into DC “half-waves”. A capacitor is needed before U6 to deliver a more or less constant DC voltage to power the regulator chip 78L05. The dropouts at TP12 you see in the screenshot are caused by the voltage on the DC or “half-wave” side drops below 5 V. The capacity of C5 must be high enough the hold the voltage well above 5V to ensure that the regulator U6 is working properly.
There is no shortage behind U6, all that happens is that the capacity of C5 is not high enough. As said before that might be caused by aging (dry out) of C5. I placed the 100 uF capacitor in parallel, because it is very hard the get the whole board extracted from the power transistors. That was the easiest way to fix the problem :wink:

You are right, my apologies, I have read your previous message differently. Thanks for explanation. It makes perfect sense to increase that capacitance, and, perhaps, completely replace the old cap altogether with a better one, including the one post U6. As you know they fail in different ways. Would be interesting to see what C5 reads capacitance and ESR wise given its age. I see a new cap on the extended lead, it probably reduces its efficiency a little bit.

Yes, I also think that it might be interesting to read the values of the old capacitor. But it is really hard to separate the board from the power transistors and the the heat sink. The transistors are placed behind the board on the heat sink and soldered from the front. Desoldering might cause damage to the parts, so I decided not to do that unless it is really needed…

1 Like