PWD MKII Bridge II MQA unfolding issues

Hi there

I am new to this forum.
I am experiencing MQA unfolding issues with my PerfectWaveDac MKII Bridge II.

My setup:

  1. PWD MKII (with latest software version 3.0.4 installed)
  2. Bridge II installed and connected via 1.0 m Supra Cat8 ethernet cable to a TP-link network extension router. When navigating through the Bridge II menu this is what I find:
    2A. It does not display the current bridge/software version anywhere?
    2B. The ‘Firmware update line’ in the lower panel of the first bridge menu section states ‘N/A’ (found directly below the wired network menu access point) and the to the left of that a check mark (found directly below the wireless network menu access point)
    2C. In the wired network menu, I find that the Bridge has automatically and adequately updated the network addresses (e.g. IP/Subnet/Gateway) and in addition I have entered these network addresses in the manual network address section.
    2D. When going back to the very first section of the menu (e.g. the music playback section) it states ‘connected to network’.
  3. Mac Mini 2021 version (+500 GB HD, 8 GB RAM), wired via 0.5 m Supra Cat8 ethernet cable to same router (e.g. TP-link network extension router) with wireless connection option disabled.
  4. Audirvana latest version installed on my Mac mini (the 1st media player option I tried)

Audirvana with PWD MKII Bridge II:

  1. At first, Audirvana could not detect the Bridge as an UPnP device. After manually entering wired network addresses in both the Bridge II and the Mac Mini and disabling wireless option in the latter, Audirvana was able to detect the Bridge.
  2. When Audirvana DAC option is set to ‘MQA Decoder’, Tidal MQA files are transferred but not unfolded. 16 bit 44.1 kHz Tidal MQA files are played back as WAV 16 bit /44.1 kHz, 24 bit 44.1 kHz as WAV 24 bit 44.1 kHz etc. without any unfolding to occur.
  3. When Audirvana DAC option set to ‘MQA Renderer’ or ‘Not MQA’, Tidal MQA files are unfolded - at least partly - so 16 bit 44.1 kHz MQA files are played as WAV 24 bit 88.2 kHz although the PWD MKII does not seem to perform any unfolding and does not recognize the input as MQA but rather as WAV. I have tried to unpower/power up the involved devices in different sequences with the
    Audirvana ‘Auto-detect MQA devices’ option set as both enabled and disabled. Still, the Bridge II does not seem to be able to recognize or unfold MQA files.
  4. The same is the case when I play back MQA files using the USB input to the PWD MKII using a Supra 2.0 USB cable.
  5. However, the SQ with Audirvana connected either the PWD MKII Bridge II via UPnP or directly to the PWD MKII DAC via USB , regardless of the issues outlined above, is absolutely fantastic in my set up (Nordost flatline red dawn interconnects, Lavardin ITx integrated amp, DIY braided 2 x 1 cm2 copper speaker cables bi-wired to ProAc D30 response loudspeakers).

NB: I also tried to play back Tidal MQA files via the MConnect App (2nd media player option which I tried). Here, MQA files are transferred and played back as FLAC-files, no unfolding appears to take place, e.g. 16 bit 44. kHz MQA files are played back as 16 bit/44.1 kHz etc.


  1. What is the most likely root cause of the MQA file unfolding issue? - is it related to the Bridge II, the network configuration and/or Audirvana?
  2. How can I check whether the Bridge II is running the latest software version? - please note that it does not feature the current version anywhere in the bridge menu (??) and, although the device is connected to the internet, the ‘Firmware Update’ panel displays ‘N/A’ and after that to the left a check mark.
  3. If these issues cannot be resolved with the current hardware, would it be possible to update the PWD to a DirectStream DAC and would that be helpful solving the MQA issues ?

Any inputs/suggestions will be greatly appreciated.

Thanks in advance.

Esben Selmer Buhl, Norway

Welcome, @Esben_Selmer_Buhl !

Hi Esben,
You should check out this thread regarding MQA unfolding using Mconnect / Bridgeii, not great news I’m afraid;

1 Like