PWT won't power up


#1

My PWT won’t do anything when powered on. It was working fine, then after I upgraded the firmware on my P5 it won’t do anything. No initialization screen and no light from ethernet port. I was running the latest firmware, tried to reinstall it just in case, but nothing. There is power coming from the P5, I even tried plugging the PWT directly into a wall outlet. Switched cables and it’s not a cable problem. Is my fuse blown or is it something else?


#2

Welcome!

The most likely suspect is indeed the fuse.


#3

Thanks Elk. Looks like that did the trick. Now any suggestions as to which fuse to use and where to get it? I know they are 1A 5x20, but any specific brand recommended?


#4

Excellent!

I am not a fuse aficionado and, thus, do not have an opinion on brands. My guess fuses make less difference with a transport than with a DAC, but I can rationalize that a short piece of wire might make a difference in the power supply of a transport.

The fusers should be along shortly to help.


#5

I think it would be wise to make sure you know, or at least have a good feel, for why the fuse blew before going the audiophile route. I say that since fuses don’t normally blow unless there is a fault. If you know what the fault was and feel confident it won’t happen again, go for it. The concern here is blowing $50- $100 fuses on a regular basis gets expensive! Not to mention keeping a stock of them so you don’t have to wait to use the PWT (or DS, or …).