ROON settings for MQA & Bridge II (new firmware)

#1

Now that we have updated firmware in Bridge II i am wondering if i need to adjust some settings in ROON.

For PS Audio DSJ playback of MQA files via ROON to Bridge II , what are the implications of making Roon a playback decoder, renderer, or both? There is also a toggle switch: Enable MQA Core Decoder. Any one have an idea of the implication of having it on or off?

If there are trade offs to these setting, i want to maximize sound quality.

DSJ Bridge II Roon Issue
#2

First thing to try is:

  1. Turn the volume down to something reasonable
  2. Play any hi-res PCM file - 88.2/24 or higher
  3. Listen for a few seconds
  4. Pause / stop playback in Roon until the ‘signal path’ light goes off.
  5. Hit the play button to re-start playback from where you left off.
  6. Pause / stop playback in Roon until the ‘signal path’ light goes off.
  7. Did you hear a loud scratchy pop as the signal path light went off?
  8. If you did, then fallback to Bridge 3.5.1 and tell Roon your DSjr is a ‘decoder only’

See Bridge 2 previous firmware
@wilsontw @zoicoster

#3

@pbphoto - I’m sure I’m missing something. I did this and didn’t get a scratchy pop so I should assume what?

#4

I have mine set to Decoder and Render. I guess the best answer would be to try switching and see what you like. I personally haven’t changed anything.

#5

I also have mine on decoder and renderer. I haven’t changed the settings since upgrading to Snowmass and the latest Bridge. On MQA files I’ve been happy with the sound so far. And the Bridge update (which adds a few seconds delay at the beginning of a new piece of music) solved the earlier problem I was having when switching between different files (CD quality, MQA 96, etc.).

#6

@michaelhifi If 3.6.17 is working for you, then yes, set Roon to both decoder and renderer. Roon’s signal path should preserve the MQA bits all the way through to the bridge II - even if you are using DSP and/or volume leveling. The DSjr will tell you it is receiving an MQA stream. There are some differences with how Roon implements MQA depending on whether or not you are using DSP or volume leveling. Here’s an excerpt from a post from Bryan Luczkiewicz, the CTO of Roon.

In general, Roon’s goal is to make sure that MQA files are decoded whenever possible.

If Roon thinks your DAC can decode, then it’s going to skip software decoder whenever practical, but engage it if you have configured DSP in Roon (this is because DSP must happen post-decode–this is just how MQA+DSP work together).

If Roon thinks your DAC has rendering capabilities, then it will:

* Ensure that the software decoder produces rendering instructions (assuming we are core decoding in software at all)
* Preserve the rendering instructions prior to any DSP performed in Roon
* Restore the rendering instructions after any DSP performed in Roon
* Disengage Roon’s upsampling when playing MQA content, since this would make it impossible to restore rendering instructions.

It sounds like your goal is to make sure that software decoding is turned off whenever possible. Roon is already designed to do that, because that is the correct behavior for playing MQA. You don’t need to use advanced settings to get that outcome.

The mental model wherein you worry about DSP+Room correction disrupting the stream is outdated. There are MQA-sanctioned ways for applying DSP to MQA streams, and Roon has implemented them. If you want to use DSP, use DSP. If you want to be bit-perfect, turn off the DSP.

The second setting–Enable MQA Core Decoder–is a way to make sure that the core decoder never runs no matter what. The problem with turning that switch off in your situation is that if you turn on DSP, you’ll end up with worse sound quality than if you had just left the settings alone.

2 Likes
#7

Very helpful - thank you!

#8

I have a question about Roon. I can’t seem to get Roon to play a a cd from Itunes library as the cd is tracked. I don’t have shuffle active, and yet when I play a cd in Roon from the play now it jumps around and never plays from track 1 to last track. It used too. Anyone have thoughts? I gotta be overlooking something??

#9

i would suggest you ask this question in the Roon forum also.