Snowmass DirectStream Junior is now live


#223

“Were the release notes posted somewhere? Can someone confirm if the SACD “pops” were addressed? What about the remote volume issue? Thanks…”

This is my third attempt to get these questions answered – Can a PS Audio employee please advise? On the remote “bug” issue I was previously told it would be fixed in the next (snowmass) releases. Many thanks…


#224

If anyone takes PS Audio up on this generous offer, please let us know if this solves your problem.


#225

It may be most efficient to send an email to PS Audio service directly. This is a long thread and your request may get lost.


#226

YES. His last Opus… Not directed at you or anyone else. Difficult doing this outside on my phone.


#227

It might be “most efficient”, however, it doesn’t help the extended community who potentially have the same questions…


#228

No, I meant I was stressed from driving over 100 miles in heavy rain.
But in general, fed up with his tone.


#229

Thanks! I’m trying to track everyone’s thoughts and was potentially getting lost.


#230

Understood; letting everyone know is important, but if you contact PS Audio directly and get a reply you can post it and let the rest of us know. Again, it is exceedingly easy for individual requests to get lost in a huge thread. This would be unfortunate.


#231

I neither meant to imply anything about anyone’s intelligence or that you weren’t having a valid problem. I believe it often turns out to be one sort of issue or another with the USB formatting, procedure or the stick itself - at least going by the number of folks who later report that they got it to work. I agree it ends up being WAY more work than it should be for many, and simply doesn’t work at all for some.

The whole idea would be to help resolve these sorts of things, and I’m not making this up in some sort of grandiose bid. I began discussing this with Paul in the Spring of this year. I was unaware that he had hired James with that as part of his duties.


#232

I normally have issues upgrading so I follow Ted’s advice pretty closely. I also buy new 16gb usb drives for each release to make it easy to go back & forth.

This morning I went back to Yale before updating to Snowmass and it worked perfectly (following Ted’s normal instructions).

My first impressions echo most of what has been said. Immediately noticeable to me was the wider/deeper soundstage. It also sound to me like a layer of harshness was removed. And as others have stated a slightly forward vocal (although this is a positive for me because I thought they were slightly recessed with RedCloud).

Outstanding job again Ted & Paul! Thank you.

Now if I can only figure out why my Bridge stopped working after the Bridge update. Just noticed today. I have a message out to Support


#233

The update problems have nothing to do with the FPGA. The FPGA is dynamic RAM and as such is pretty well scrambled by a loss of power. The unfortunate bug that just after an update sometimes things sound better after one more reboot could be in the FPGA, but actually I suspect the display processor not booting the same after an update as it does on power up. The display processor’s memory is very likely different after running than just after a power up. (PS Audio is aware of that possibility.) All of that isn’t to say that the FPGA is perfect: there’s always the chance that I swept some timing thing under the rug and that “the gears can slip” so to speak so one section of the code is not speaking when the next is listening or something like that. I keep my eyes open for such possible bugs every time I’m working on the code, but those bugs have the symptom that after a while you notice that things aren’t quite right and reboot and things sound great again.


#234

Definitely sucks that so many are having install issues. I can only imagine that it’s the device itself that doesn’t have the proper drivers to recognize every USB stick out there.

Fortunately I’ve had good luck with a 8gb stick. FAT32 format. Nothing else on the stick. Place the 4 files on the USB (NOT THE ZIP), eject and install. Given I have to downgrade to Yale every time I do an upgrade, I’m familiar with the process enough.

But I’m a Windows 7 users. Maybe that’s part of the problem for others is that they’re Windows 8, Vista, MAC (of various OS versions)…

Hope you guys get it sorted out sooner than later! And please take your quibbles about various users elsewhere. It pollutes a thread that should be full of listening impressions/install assistance than anything else.

Thanks in advance.


#235

Interesting, now I know a little more about FPGAs. So I guess it’s a bit of mystery.


#236

Regarding Bad Beef. These are customer feedback and support forums. To me, his tone often comes across as unsupportive to the customer. It’s important that we be able to freely express both the joys and pains of the PS Audio experience. Important to PS Audio as much as anyone.

BB’s tone seems to be defending the PS Audio team in a way that is counterproductive and unnecessary to all parties involved, and that ends up sounding condescending to the customer, without whom there would be no PS Audio.

If BB genuinely wanted to work for PS Audio, he’d do well to emulate their amazing customer service ethos instead of contradict it.

The issues expressed here are certainly experienced by a much larger swath of customers whom do not participate in the forums. Which is what makes honest feedback so valuable to PS Audio and customers around the world.


#237

I’m with you Dirk. I believe the upgrade path is important and am puzzled why PSA takes the bugginess of it so lightly. I’m an ex-Software Developer and am able to deal with it. After several tries going straight from RC to SM, I punted and successfully did the downgrade->upgrade route. For me it wasn’t too big a deal, just a bit of head shaking as I walked back and forth behind my audio cabinet for the 5th time.

This is a product that markets it being upgradeable. Trial and Error Upgrading is not a positive feature. Yes it is a DAC first and foremost, but if it’s marketed as upgradeable then it should work without a need to be computer savvy or asking you’re uncle drive 50 miles to help you. If downgrading first is the fix (which is acceptable) then make that the prescribed path for all upgrades and end people’s anxiety.


#238

Thanks for the reply , will get on to it.


#239

Thanks to you also for the reply . If I can make a comment the download was only 560kb. Is that right?


#240

Since I upgraded I tried some SACDs and found no pops whatsoever. So far, so good.


#241

dancingsea - I agree with your assessment. Forums are there to raise questions and make comments. I think it is fair game for people to yell “It ain’t working” and then 20 posts later say “Problem Solved”. If anything that in itself is valuable feedback to PSA as they do get a pulse of their community and that maybe the upgrade mechanism is broken. Broken very well could mean, insufficient documentation, does not have to mean software, firmware or hardware.

I also find it somewhat amusing the BadBeef is auditioning for a job to be liaison between PSA engineers and PSA customers. He seems to have annoyed quite a few customers of late (in fairness I’m not one, but can’t help but read all the upset stomachs over eating badbeef). Seems like keeping customers happy would be an important skill. :grin:


#242

@wilsontw I have the exact same problem. I downgraded bridge to 3.5.1 to fix - gave up MQA but I don’t care. This problem seems to be related to bridge 3.6.17. It did it on 3.6.2 as well. Not related to either Snowmass or Red Cloud.