Software Download Issues


#1

Man, I am so frustrated trying to update the software on my PWD Mk II. Is it absolutely necessary to use a 2GB card? Nobody sells 2 GB cards anymore except over the internet, and the prices with shipping are a complete ripoff (apparently various devices such as the Wi game console and maybe some cameras will only use a 2GB card so the vendors charge much more for 2GB cards than larger GB cards because they have people over a barrel ). Then if you can’t get the unzipped software to download to the card, you have to figure out whether it is the card or the reader/writer. So you either have to buy another reader/writer or order another 2GB card over the internet and wait a week for the new card to be shipped to you to see if that works.

I would like to try a 4GB card from the local Best Buy and pick up one of their reader/writers to see if I can get the software to download. Again, will a 4 GB card work?

Also, what is the latest software for the PWD? It looks like there is a 2.4.6 in the downloads, but I haven’t seen any discussion of it on the forum.

It is extremely frustrating that such an awesome piece of audio equipment requires such a painstaking effort to update the firmware (or else you have to send the unit back to PS Audio for an upgrade). Sorry for the rant, but I’m ready to pull my hair out after working on this for an hour and a half.


#2

Sorry to hear of your trouble; I just updated my PWD with 2.4.6 without problems.

I use a MacBook Air, and deleted all the previous files on my 2 GB card (formatted on a MS-DOS computer to FAT 32).

Must be formatted on a non-apple computer, IIRC.

I dragged each file from the unzipped download to the card. Six files total.

Turn off the PWD in the rear, insert the card with contacts facing up, turn on the PWD and LET THE PWD RUN FOR SEVERAL MINUTES until the blinking stops and the screen appears normal.

Turn off the PWD in the rear, remove the SD card, then turn on again in the rear.

While the PWD says “Initializing”, touch the PS symbol in the center of the touchscreen, and confirm that the desired version is loaded.


#3

It is an odd situation; most of us have zero issues changing firmware but some have significant legitimate problems.

Let us know how it goes and we will help.

(I do not recall needing to format the card on a PC, Apple users?)


#4
pesgas said I would like to try a 4GB card from the local Best Buy and pick up one of their reader/writers to see if I can get the software to download. Again, will a 4 GB card work?
IIRC from other posts, some people have successfully used cards larger than 2GB--I think someone used 16GB. It won't hurt anything to try. Since you have to order 2GB cards online anyway, a while back I bought a 4-pack for not much more than they charge for one. I keep them around for my PSA gear.

#5

I’m going to buy a new reader/writer today and a 4GB or 8GB card so I can at least determine whether I have a bad reader/writer, bad cards, or some combination of the two.


#6
audiobill said

Must be formatted on a non-apple computer, IIRC.

Not true. One can use Disk Utility on an iMac (or Mac mini) and select MS-DOS (FAT).

#7

Wybe, does that result in FAT32 or FAT16? I have successfully used FAT32 but FAT16 is recommended. I think I had to use a PC to reformat as FAT16 but it’s been awhile.


#8

It appears I had a bad reader/writer, as I was able to download to the files to a 2 GB card using another reader. No problems there. But when I put the SD card into the PWD and turn it on by the rear switch, nothing happens in terms of a firmware upload. It just turns on the PWD. I guess I’ll try reformatting the card next.


#9

Reformatted the SD card on my PC. It reformatted and I transferred the 2.4.6 update to the SD card. Still no response from the PWD. Will try a different SD card and a reformat of that card. If that does not work, will cut head off live chicken and sacrifice virgin (if I can find one). Aaarrgh!!!


#10

A full reformat (as opposed to a quick reformat) of a second SD card seems to have done the trick. This time the PWD started the firmware upgrade process, but then it froze at the initializing stage. I called technical support and they were going to send me some “force code,” but just as a lark, I tried turning the unit on and off again from the rear switch and this time it seems to have completed the process, and then it initialized, and the unit indicates that 2.4.6 has been loaded. I will trying using it tonight to see if it works okay.

Live chickens and virgins are safe - for now.


#11

Let us know how yours sounds-mine sounds great!


#12

Excellent!


#13

2.4.6 sounds great to me. I’m not sure if I could say I hear a difference between this latest update and what I was running before (2.4.3), but I don’t seem to have any issues with it after getting it loaded, and overall I’m very pleased with what I’m hearing.


#14

Be sure to save this SD card for future revisions; it’s formatted and it works!


#15

read all comment from this subject… I extremely hope to know…

Really? those SD card larger than 2GB can be applied and used on Perfect Wave product??