Quick help question on FW update on PWD


#1

Hi, I have a PWD Mk II w Bridge that I haven’t used in a while. I’m now trying to update the firmware (2.4.4 and bridge 2.15) and I’m having trouble getting the PWD to switch into firmware update mode. Current firmware is 2.0.2 (bootloader 1.02, USB 1.03). I have two PS Audio supplied 2GB Sandisk FAT16 cards, one with 2.2.0 and one with 2.4.4. Neither SD card (inserted correctly) triggers a firmware update. I’ve ready quite a few posts here on correct approach and believe I’m doing all the right stuff (unplugging other devices including power, re-attaching only the power cord). I’ve held down the front logo switch and it goes into screen calibration. I can touch the logo on the screen and it goes into the version screen. But no firmware loader. Was there a different method to trigger this back in the days of 2.0.2?

Thanks!


#2

Sometimes it can be a bit finicky even when you’re doing everything right. Have you tried reformatting a card (on a PC use full formatting, not quick) and using a fresh download? It’s possible a file got corrupted although the odds of that happening on two cards seem a bit high. From what you said, I assume files are unzipped and at the root level (not in a folder) and pins are facing up.

Edit: The method is the same regardless of which version you have now.


#3

What Steve said:

extract all files to the root of the SD card. That should work whether there is other stuff on the card or not, but it is best and easiest if the card is empty to start with.

Power cycle the PWD using the switch on back or pull the power cord. The front button is just a standby switch that mutes the output and blanks the display, it does not turn the power off for anything in the DAC.

J.P.


#4

Hi yes have been doing everything per your suggestions above. Everything zipped, extracted and placed at root of the card. Have reformatted one of the cards as well now. always using power switch in back, also pulling power cord for 10 min or an hour in one case (and unplugging all other cables). pins up on SD card each time. have also re-downloaded the 2.4.4 files again. will see if that makes a difference. Seems like I’m doing all the right things, so will give it a few more tries, reformat, new download/extract/copy to root, full power cycle, etc. and hopefully will get lucky… thanks again


#5

I assume you meant to say “unzipped”?


#6

yes, unzipped smile

EDIT: I should add, the Bridge has updated no problem to 2.15. I did this over the web interface via File method selecting the 2.15 “ub” file locally. DAC still at 2.0.2 and stubbornly refusing to boot into firmware update mode (wish there was a way like in PC-land to force it into SD card mode / firmware mode).


#7

Have you tried to load another version of the firmware other then 2.4.4?

Perhaps your unit will be willing to upgrade to another version first.


#8

Definitely what I was thinking too. I tried the earliest firmware in the downloads area (2.2.0) and same result (no update). Would be interested in trying a version in between to see if that triggers a response.


#9

You might also try multiple times with the same card. It seems that sometimes it just doesn’t want to recognize the update but I’ve never encountered this level of stubbornness.


#10

My just right amount of OCD had me try it no less than 30 - 40 times surprised-014_gif


#11
I also have this question. I have a PWD mk2 that was upgraded from mk1. I have been on firmware 2.0.3 since I purchased the device. I have a 2GB Sandisk SD card (not ultra) that is formatted to FAT with update files on it. I've tried it many times over several different firmwares and tried reformatting it with different block sizes and even FAT32. I reset the power every time I reboot my PC because I have to for the device to be recognized and it still reports the same firmware (the SD card with the updates are always kept inside it, inserted properly with pins up). Yes, all files are properly unzipped onto the root of the SD card. The only thing I can think of is to upgrade to a lower firmware first. I have a copy of every firmware ever released.
I didn't let it bother me because 2.0.3 worked well and had decent quality. However, 2.4.5 seems nice and trustworthy now. Anyone care to give a recommendation on how I can get the DAC to upgrade finally? My conclusion is to possibly buy another SD card possibly, but I have no clue what SD card would be better than the recommended.
EDIT: Ok, the logo flashes really fast a few times on some boots and then it quickly boots up. However, my firmware has NOT changed. I've tried re-extracting the files, so on. This isn't working.

#12
manaox2 said
EDIT: Ok, the logo flashes really fast a few times on some boots and then it quickly boots up. However, my firmware has NOT changed. I've tried re-extracting the files, so on. This isn't working.
Have you checked (in a text editor) that the loader.cfg references the correct FPGA and PIC files hosted on your SD card and where to put it into the DS memory (EEPROM, I presume)?

If there is a mix here, it won’t work (I experienced the same thing a while ago).

Could you report the content of the loader.cfg and list the SD files herein?


#13

I’ve found that the boot up is in two phases - be sure to let it go through both, a few minutes.


#14

I suggest a fresh start.

try installing another version like 2.2.0 or 2.1.0 etc and see if the logo flashes and installs. Ifl

not, there is an sd card issue.

if it does change the version, then re download the desired final version, cold boot the dac ( cord unplugged for a few moments) WITHOUT THE CARD, reinsert the card and give it a go.

hope this help to get you where you wish to go.