Spotify Connect and WAV


#1

Hi all!

Finally upgraded to Bridge II… the new streaming options inspired me to get back into it, hopefully resulting in us ditching our Apple TV except for playing our library… until Octave!

Anyways, I’ve been playing with both Tidal and Spotify. Tidal registers FLAC or MQA. But with Spotify, the DS registers that Spotify Connect is streaming WAV. Anybody noticed that? Is that possible?

I also noticed that I can’t change stream quality settings with Bridge II like I can when playing through my phone or Apple TV.

Thanks!

John


#2

That’s correct: you can’t change quality stream settings while you’re using Spotify Connect (for the Bridge II). So, connect to your phone itself, change your settings and than connect again to your Bridge II.


#3

My DAC reports Spotify as 44.1 kHz PCM. I’m pretty sure my DSJ reported the same thing.


#4

Same here, but the source is 320 kbps lossy.


#5

Considering that the DS has been accurate in determining file type/size for everything else I’ve streamed to it, any thoughts on why Spotify is inaccurate?


#6

The DS is displaying what it is receiving. Mp3’s played over Roon display as 44/16 WAV files. Spotify is using lossy compression but they are still 44/16 files. I would think Spotify Connect is doing the same thing as Roon–decoding the lossy compressed files to 44/16 WAV files before sending them to the Bridge. This contrasts to JRMC, where mp3’s display as mp3 44/16. In that case presumably the Bridge then converts the file to WAV for internal processing.


#7

I was wondering around this subject too. I have a PC connected tvia USB to my Jr. It shows 192-24 when I play Spotify. I do not have the paid service but that seems pretty lofty. Sounds great though…


#8

Your PC may be upsampling for some reason.


#9

I’m not sure how. I have Roon but it’s closed. I just log into Pandora and/or Spotify and the DAC shows 192. My guess is I set the Default format at max (below) and for some reason the DAC sees this even though it is not accurate?

Capture-1.PNG


#10

Spotify and Pandora don’t allow for exclusive control over the audio output like other applications do. For that to happen the application would need to have a WASAPI exclusive or ASIO output mode. So Windows outputs everything to the default format that you’ve set. Windows doesn’t normally upsample the audio. It just pads the bits. So in reality you’re still only getting 16/44.1 audio. It’s just hiding inside a 24/192 padded audio stream.


#11
Seegs108 said Windows doesn't normally upsample the audio. It just pads the bits. So in reality you're still only getting 16/44.1 audio. It's just hiding inside a 24/192 padded audio stream.
I don't know what you mean by this. You can pad 16 bits to 24 bits in a sample, but changing the sample rate is upsampling. Upsampling doesn't change the amount of detail (or rescue or unobscure any details), but I have a hard time saying that going from 44.1k to 192k is just padding bits - it requires filtering and that may (or more likely, will not) output any of the same bits that came in.

#12

Clearly I hadn’t thought about that aspect of it. I suppose it would be best to set 16/44.1 as the default in Windows with the box ticked that will allow for other applications to take exclusive control over audio output. Spotfiy and Pandora only have 16/44.1 audio anyways. This should fix everything given you have any applications with higher resolution audio set up properly.


#13

You guys are much more expert than I. The DAC reports accurately in Roon which really is all that counts. I just wondered why it would report 192 and/or what was fooling it. And I believe when setting up Roon that I wanted to choose that higher / highest setting. In Roon, I do use WASAPI and Event mode but that’s probably a whole different thread. In short, works great and even sounds better with the DSD regardless… I also have the “exclusive control” box checked…Thanks for shedding some light here guys…