Sprout100 + Linux USB

I know that Linux is not officially supported, but was just wondering if anyone on the forum has had success using a Sprout100 connected to a linux machine via USB2.0? I’ve got a Sprout100 on order and am wondering if it is likely to play nice out the box or if I’m going to have to get my hands dirty with some hacking to get it talking to the laptop… Does anyone know if it presents as a USB Audio Class 2 device?

What’s the goal? To have sprout boot the os off usb or see storage?

I don’t have a Sprout but I do have a NUC running roon ROCK connected via USB to my SGCD and it recognizes it as an audio device. It is my main source for music. I would expect it to work.

I used a Raspberry Pi running Ropieee to stream Roon around the house with the USB port on the Sprout 100 and even got to try upsampling to DSD. Worked flawlessly.

I just got my Sprout100 and have been trying to get the USB input to work with alsa on Raspbian Stretch, but keep getting kernel errors:

usb 1-1.1.2: 1:2: usb_set_interface failed (-71)

Does anyone know if there’s a flavor of Linux that supports the Sprout?

Raspbian means you’re running a Raspberry Pi. I’m surprised that it’s not working, perhaps there’s a driver package you need to install? But one that works out of the box is DietPi.

Hey, Robert! Nice to see you over here. Yep, it’s a Pi.

No luck with DietPi either – which also seems to be based on raspbian stretch. When I run a speaker-test, dmesg spits this out, both with and without the bcm2835 kernel module loaded. Other USB peripherals work.

[  839.351501] usb 1-1.1.2: 1:2: usb_set_interface failed (-110)
[  849.924265] usb 1-1.1.2: 1:2: usb_set_interface failed (-71)

Can you try the Sprout with a different computer and OS to rule out the Sprout’s USB being defective? I’ve used DietPi with the Sprout before without any issues (just switched to using a ChromeCast Audio though).

Yep, USB to my Mac works fine. I think I’m going to check out the Hifiberry to connect the Pi to the Sprout over Toslink.

So I just plugged my Pi into the Sprout again, and here’s what I’m seeing:

[ 10.441477] usb 1-1.2: new high-speed USB device number 5 using dwc_otg
[ 10.572089] usb 1-1.2: New USB device found, idVendor=2616, idProduct=0113
[ 10.572102] usb 1-1.2: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[ 10.572111] usb 1-1.2: Product: Sprout100
[ 10.572119] usb 1-1.2: Manufacturer: PS Audio
[ 10.575671] input: PS Audio Sprout100 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.3/0003:2616:0113.0001/input/input0
[ 10.641739] hid-generic 0003:2616:0113.0001: input,hidraw0: USB HID v1.10 Device [PS Audio Sprout100] on usb-3f980000.usb-1.2/input3
[ 10.734922] usbcore: registered new interface driver snd-usb-audio

I’m not seeing a package called snd-usb-audio, I figure it’s just a generic USB audio driver. Can you go into dietpi-config and under Audio Options, Soundcard select usb-dac (last option in the list).

Also, do an lsmod – do you see snd_usb_audio listed there?

Wait, so you’re connecting the Sprout as a USB 1 device? Mine tries to connect as USB 2.0. What model of Pi do you have? And what version of DietPi/Raspbian. I doubt connecting as USB 1 would work for streaming high quality audio.

[    2.352195] usb 1-1.1.2: New USB device found, idVendor=2616, idProduct=0113
[    2.352204] usb 1-1.1.2: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[    2.352212] usb 1-1.1.2: Product: PS Audio USB Audio 2.0
[    2.352219] usb 1-1.1.2: Manufacturer: PS Audio Sprout100

Also, when you run aplay -l do you see something like:

card 1: P20 [PS Audio USB Audio 2.0], device 0: USB Audio [USB Audio]

Hey, at least mine’s connecting at all! :wink: Also, USB 1.1 can do 12Mbit/s, that’s plenty for audio data.

aplay -l says this:

**** List of PLAYBACK Hardware Devices ****
card 1: Sprout100 [Sprout100], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

So not very helpful with regards to USB 1 vs. 2. I’ve never had a problem with dropouts, though.