Using Sprout100 as DAC for Volumio on Raspberry Pi?


#1

I know a few Sprout owners have been playing with the Raspberry Pi. I was hoping you could offer some advice to me regarding Volumio. Volumio detects the Sprout100, but I don’t hear any audio coming from it.

I see a few error messages as well.

I meant to post my configuration as well, but my account is limited to one image.
Suffice it to say that my output device is: PS Audio USB Audio 2.0 and my I2S DAC is marked as OFF. If I turn it on, it won’t let me save PS Audio as my output device.

DSD Playback Mode is set to DSD Direct.
My mixer type is SOFTWARE.

Any suggestions would be appreciated.


#2

I’ll try.
The RPi is being used as a streamer outputtting via USB to the Sprout100 usb input, whose knob is set to Digital? Is that the chain?


#3

That is correct.


#4

Ok. Although I run spdif out of my Allo DigiOne, these are the options I have set.


#5

In the Output Device section, when you try switching, always wait for the audible tone confirmation, it takes several seconds after each time, or restart the RPi if over a minute.


#6

Thinking a bit more…so from the Sprout, you output the signal to another amplifier?, if so, I wonder if the sprout knob needs to go to analog to output the incoming signal…?


#7

Thank you for the replies. I do not route the output of the Sprout100 to another amplifier. I configured Volumio nearly identical to yours (save using the Sprout100 instead of your digione). I still got errors. I rebooted the Pi and got the same errors.

image

I have been able to use my USB-based Soundblaster Omni 5.1 on the Pi and routed to my Sprout100 through analog, but the DAC isn’t as good as the Sprout100’s, so that is a less desirable option.


#8

just noticed this… sprout wants to be set to digital if acting as a DAC. (At least that’s how it worked for me. The mac mini’s audio out recognized the Sprout only when the digital input was selected.)


#9

That may work. It’s really up to the RPi recognizing it.


#10

heh, well, here’s an oddity. My amp is no longer playing the USB dac signal coming from the sprout. Hmmmm…

(Roon shows it’s playing; it sees the zone; sprout analog out is going into an aux input on the amp… nothing.)

Must be a stupidly simple explanation. :thinking:

EDIT: works with optical but not USB. (Although sprout volume needs to be turned up… Shouldn’t it just be pass-through?

double hmmmmm…

EDIT #2: working again. No idea.


#11

Did you have both USB and optical connected at the same time? If so, Sprout would select one of them. Sprout’s analog out does go through the volume control. You are basically using it as a pre-amp as well as a DAC.


#12

yep, I remember the Sprout favors USB over optical if both are connected, but I only had one connected at a time. Odd. I think it may just have needed a reboot of the Roon app. Not sure. Tried a few things, then it started working.

I suppose you’re right, that it acts as BOTH a DAC and a preamp. No way to do an either-or.

Anyway, I ordered a Topping D50; should be here tomorrow. Interesting to see how that will work.


#13

If anyone happens upon this thread with the same issue, I solved it by installing a HiFiBerry Digi+ Pro to the Pi. That gives you an optical out, which attaches to the Sprout100. I am listening to FLAC with no issues so far. It sounds fantastic!